Jetpack: og:title not correct on automatic posts

Hi,

first of all: I really love your support????

I use the Jetpack publicize component to post automatically on Facebook. I also use Yoast SEO to define individual OG-Titles.

My problem is:
If I post automatically with Jetpack Publicize on Facebook, the OG-Title from Yoast isn’t used. However, if I post the URL manually on Facebook, the correct OG-Title from Yoast is there.

I guess, that automatic posting on Facebook by Jetpack is done before Yoast’s functions are executed? Do you have an idea for a work around on this?

Thanks in advance for your replay.

  • Katya Tsihotska

    Hi Jonas

    Hope you are doing fine today!

    I was able to replicate this issue. But I can't tell for sure why it happens, I also wasn't able to find any relevant information on this. I suppose that JetPack Auto-Publicize simply use common post's fields (title, content, feature image) and it doesn't "realize" that you are using Yoast SEO.

    But when you try to manually post the URL on FB it works fine because Yoast SEO adds og tags to the <head> section of the page, so there is all needed information to create a correct post.

    I'm not sure how you can fix it, it would be better to ask JetPack support team, as they should be more familiar with their own product. But meantime, you can use JetPack Publicize settings to set correct title:

    There you can set your custom title for JetPack Publicize.

    Hope it helps! Please feel free to ask more questions if you have any.

    Kind regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.