Jetpack share buttons don't show up on custom post type single pages

I use CustomPress, and have created several post types. Everything on the site is working great. I use Jetpack’s sharing buttons.

However, on a single post view for my custom post types, the sharing buttons don’t appear.

According to the Jetpack documentation, custom post types are supported, and supposedly on the Settings->Sharing page you should be able to check which custom post types show the sharing buttons. For me, that page is only showing the default custom post types.

I am using the most up-to-date version of Jetpack and CustomPress.

Any thoughts?

  • aecnu
    • WP Unicorn

    Greetings cjseattle,

    Welcome to WPMU DEV!

    Sorry to hear that you are having issue with JetPack and Custom Press combined.

    It can be pretty challenging to support other peoples work, but we do our best here to help you if we can.

    Since I have no clue as to why this issue could be and I do not use Jet Pack on anything, I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Arnold
    • El Macho WP

    I just tried it here and had no problems. I have Director and Classifieds, which are Custompress installed and I added a jetpack cutom post type with default settings to test. Shows t,he custom pst type and shows the button on the page, so I'm at a lose.

    Sure you dragged the services down into enabled services?

  • aecnu
    • WP Unicorn

    Greetings cjseattle and Arnold,

    Happy New Year to you both.

    @arnold freaking fantastic and thank you for teaching me something new today!

    @cjseattle There we have it straight form the lead developer and demonstrated in his awesome screen shots.

    Please advise how this information has indeed worked out for you.

    Looking forward to hearing form you in any event.

    Cheers, Joe

  • cjseattle
    • New Recruit

    I think I’ve given up on this one. I understand that Arnold was able to demo a successful integration of some custom post types and Jetpack. For me, it just doesn’t work in this one case — could be another plugin conflict, I’m aware of the need to deactivate all plugins and try to narrow it down. Thanks for taking the time to look into this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.