Jobes & Experts - No Job Found

Hi,
I've got the 'Jobs & Experts' plugin installed on my clients site - http://idealts.co.uk . I can get the jobs to display by themselves, but I can't get the archive list to show any jobs http://idealts.co.uk/job/.

I've tried using the default link from page manager and using the shortcode. Nothing seems to work.
Note:
1. Experts displays fine.
2. It works on my dev server
3. It works on my local server

Finally, can you advise how people can 'contact' from the job page without needing to login?
Thanks in advance
E

  • Kasia Swiderska
    • Support nomad

    Hello Elroy,

    I've got the 'Jobs & Experts' plugin installed on my clients site - http://idealts.co.uk . I can get the jobs to display by themselves, but I can't get the archive list to show any jobs http://idealts.co.uk/job/.

    Huh, that is strange if it works on other environments but not on this one. Are those 1:1 copies? Are there any difference between them? Like used plugins or theme? Please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I'm testing this on my lab site and jobs showing there fine.

    Does the PHP version on your localhost and dev site it higher than PH 5.2?

    Finally, can you advise how people can 'contact' from the job page without needing to login?

    They can't do that. Jobs&Exerts is not Job board plugin, it was created to connect experts with job owners, so only experts can apply for job. That is why they have to have account and be logged in.

    kind regards,
    Kasia

    • Elroy
      • WPMU DEV Initiate

      Hi Kasia,
      1. They are a 1:1 copy.
      2. I've just been through the conflict test (I'd done it before, but done it again). - No Joy
      3. The live version was using PHP 5.2 against my local version which is 5.5.10 (on MAMP). I've just updated the live version 5.6 - No joy
      4. If you can't connect without creating an account, can you advise on manually changing it? (although this may be pointless if I cant get the above to work).

      Thanks again.
      E

  • Nithin
    • Support Wizard

    Hi Elroy,

    Hope you are doing good today. :slight_smile:

    Thanks for enabling support access, this is odd, since performing a conflict test didn't help much. I was able to notice browser console errors specific to your theme, but switching the theme neither helped much.

    I tried to add a new job, and was able to get that listed, but adding new ones didn't work, which is odd. To troubleshoot it further, could you please enable debug mode. To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please try to add new jobs, and check whether there are any errors related to the plugin. The errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    If you can't connect without creating an account, can you advise on manually changing it? (although this may be pointless if I cant get the above to work).

    As mentioned by Kasia, the plugin only works by connecting Job owners, and experts. I'm afraid, there isn't any other workaround for this. If you are considering custom development, you can check our Jobs & Pros section, in order to get this done custom developed.

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.