Jobs and Experts Demo data does not get created

Hi WPMUDEV

I hope you are still up

I tried to create demo data for jobs and also for experts but with noc success it gets stuck at 10% (experts) and at strange 6.6666666 (jobs)

https://www.dropbox.com/s/n5ihxiy9oh0ah80/Screenshot%202016-10-13%2022.04.58.png?dl=0

Could yu please check why those demo data does not get created.

As it is a site for Montessori teachers etc we don't use html,php,css, as skills or categories
Instead we use:

Categories:
Administrator,Handyman,Montessori Teacher,Secretary,General,Montessori Teacher (AMI approved),ESL Teacher,Physical Education Teacher

Skills:
Kindergarten,AMI approved,Art Teacher,Bachelor in Education,Master in Education,Primary School,Montessori Diplom,Secondary School

and we checked that those demo jobs and experts have also files attached as it would be the case too in reality. We tried to create 15 demos each.

Thanks

Andi

    Luís

    Hi Andi ,

    Hope you're doing well today!

    Strange, with the RC version I was able to create the demo data. I already reported this to the plugin's developer and pinged him to see if we have a hotfix to this.

    However, with the RC version installed, can you enable the debug flags in your wp-config.php?

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    Then try create a demo data. It will be saved to a debug.log file inside the "wp-content" folder. Can you share it with us to see if was saved any error related to this?

    https://codex.wordpress.org/Debugging_in_WordPress

    Note: Save the file as a .txt, because the .log extension is not allowed in the attachments.

    Cheers, Luís

    Andi

    Hi Luis

    it is set to on

    I attached the debug log file written while creating the expert / and jobs demo data.

    It gets stuck both times at 10% and nothing gets generated. It had to create 10 demo entries and got stuck after 2

    I changed the plugin to the newest one and here I saw now the following, which might is the problem with the newest version. Here no data gets generated.

    [21-Oct-2016 00:57:42 UTC] WordPress database error Column 'post_content' cannot be null for query INSERT INTO ocs_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (2, '2016-10-21 07:57:42', '2016-10-21 00:57:42', NULL, '', '', '', 'publish', 'jbp_pro', 'closed', 'closed', '', '', '', '', '2016-10-21 07:57:42', '2016-10-21 00:57:42', 0, 0, '', '') made by do_action('wp_ajax_create_demo_expert'), JE_Expert_Demo_Data->generate_data, JE_Expert_Demo_Data->_generate, IG_Post_Model->save, IG_Post_Model->perform_insert, wp_insert_post
    [21-Oct-2016 00:57:42 UTC] WordPress database error Column 'post_content' cannot be null for query INSERT INTO ocs_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (2, '2016-10-21 07:57:42', '2016-10-21 00:57:42', NULL, '', '', '', 'publish', 'jbp_pro', 'closed', 'closed', '', '', '', '', '2016-10-21 07:57:42', '2016-10-21 00:57:42', 0, 0, '', '') made by do_action('wp_ajax_create_demo_expert'), JE_Expert_Demo_Data->generate_data, JE_Expert_Demo_Data->_generate, IG_Post_Model->save, IG_Post_Model->perform_insert, wp_insert_post

    and while creating jobs

    [21-Oct-2016 00:58:09 UTC] WordPress database error Column 'post_content' cannot be null for query INSERT INTO ocs_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (2, '2016-10-21 07:58:09', '2016-10-21 00:58:09', NULL, '', '', '', 'publish', 'jbp_pro', 'closed', 'closed', '', '', '', '', '2016-10-21 07:58:09', '2016-10-21 00:58:09', 0, 0, '', '') made by do_action('wp_ajax_create_demo_expert'), JE_Expert_Demo_Data->generate_data, JE_Expert_Demo_Data->_generate, IG_Post_Model->save, IG_Post_Model->perform_insert, wp_insert_post
    [21-Oct-2016 00:58:09 UTC] WordPress database error Column 'post_content' cannot be null for query INSERT INTO ocs_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (2, '2016-10-21 07:58:09', '2016-10-21 00:58:09', NULL, '', '', '', 'publish', 'jbp_pro', 'closed', 'closed', '', '', '', '', '2016-10-21 07:58:09', '2016-10-21 00:58:09', 0, 0, '', '') made by do_action('wp_ajax_create_demo_expert'), JE_Expert_Demo_Data->generate_data, JE_Expert_Demo_Data->_generate, IG_Post_Model->save, IG_Post_Model->perform_insert, wp_insert_post
    [21-Oct-2016 00:58:09 UTC] WordPress database error Column 'post_content' cannot be null for query INSERT INTO ocs_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (2, '2016-10-21 07:58:09', '2016-10-21 00:58:09', NULL, '', '', '', 'publish', 'jbp_pro', 'closed', 'closed', '', '', '', '', '2016-10-21 07:58:09', '2016-10-21 00:58:09', 0, 0, '', '') made by do_action('wp_ajax_create_demo_expert'), JE_Expert_Demo_Data->generate_data, JE_Expert_Demo_Data->_generate, IG_Post_Model->save, IG_Post_Model->perform_insert, wp_insert_post

    ======

    I switched back to the RC Version 1.0.0.2

    Findings:

    In newest Version no data gets generated in previous one only each 2 Jobs get generated and 2 Experts each instead of 10 and it always gets stuck at 10% in experts and jobs.

    As you can see on the previous version log file the database problems don't appear here

    ---

    While fixing this I would also recommend to add 2 more fields in the mask for the demo datas.

    Company name and company URL as it is not good to have always wpmudev in the demo data section better wold be to take the owners of the site company name and his company url or like it would be best to let the demo data creator insert his favorite Company Name and URL otherwise the whole Unlimited Branding stuff doesn't make real sense as you would need to edit all reated records again by hand. The same is with those attached example file URL field which by default links to wpmudev.org.

    Also there is no way to change an image of a person! instead the demo data pulls images from the gallery - unfortunately this brought up another problem as you might see yourself as it seems images don't seem to get created properly. But as said there is no way to change them which is not useful at all. Also the images get cropped instead of resized! Cropping can result in terrible images as you can see too.

    I hope your dev can get things done, fixed, adjusted and added. Thanks!

    Debug is on! and RC Version is installed in the system!

    Kind regards

    Andi

    Andi

    Panos

    Hi Andi,

    It is possible that your site has difficulties reading the dummy data.

    I have attached a zip file which contains lighter dummy data for Jobs and Experts.

    What you need to do is:
    1. first keep a backup of your previous dummy text files. They are located at folder wp-content/plugins/jobs-plus/app/addons. For the jobs open folder je-job-demo and download file data.txt to your desktop. For the experts do the same for the data.txt file at the je-expert-demo folder.

    2. Download the zip file attached at this post and extract to your desktop.

    3. Upload and replace the data.txt files accordingly, for Jobs upload from unzip folder JE_addons_demo/Jobs dummy data/ and for experts from folder JE_addons_demo/Experts dummy data/

    Then try again adding dummy data from your settings and let us know how it works for you

    Thanks!
    Panos