Jobs and Pros crashing with bbpress integration.

hi,

this is the third site i am experiencing this on.
i cannot find my first post but here is the second post referring to the second site ;

https://premium.wpmudev.org/forums/topic/jobs-and-experts-crashing-site

so i basically created a new install specifically to test this taking every thing as step by step as possible to try and find out exactly what is causing it.

using only wordpress themes, deactivating all plugins, and slowly adding to catch the failure.
i notice it happens for sure when i click the bbpress integration and hit save changes. BOOM ! white screen of death and not coming back unless i change the plugin name via SFTP to troubleshoot further. this also leads to deeper issues with the plugin eventually not being able to delete via SFTP or install again via wpmudev dashboard.

so why do i say "Jobs and pros" ?
if i use "private messaging" alone it works fine with the add ons activated.

thinking it was bbpress, i deactivate bbpress, activated on main site only and network activated. no difference. same failure.

i got it to work fine by installing "private messaging" separately.
even using the bbpress add-on.
however once i deactivated "private messaging" plugin, BOOM failure.
i know how to deactivate a plugin by deleting or changing name but i don't know how to activate "private messaging" plugin to get site back up.

so the problem definitely seems to me to be jobs and pro messaging add-on (without "private messaging" plugin installed separately) and saving changes after activating bbpress integration.

so i am dead in the water now out of ideas.
screenshot of error logs from wpengine admin.

any kind assistance here would greatly appreciated.

  • amused

    just for future reference,
    i did a google search and the only articles for activating plugins outside of admin involved going into the database etc. and all the articles were many years old.
    as mentioned above i know how to simply change name or delete to deactivate a plugin via SFTP.
    but is there a simple way like this to activate a plugin outside admin via SFTP for future reference if i get into a similar monkey pants ?

    i know this may not be common as most conflicts would involve deactivating and not activating.
    but from my explanation above the opposite occurred.
    deactivating the "private messaging" seems to cause "jobs and pros" to fall back on its built in "private messaging" which is causing the monkey pants.

    :slight_smile:

  • Hoang Ngo

    Hi @amused,

    I hope you are well today and I do sorry for the issue :slight_frown:

    I will place a patch for you, Can you please send in:

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    This bug will be fix in next version, many thanks for your found :slight_smile:

    Best regards,
    Hoang

  • Hoang Ngo

    Hi @amused,

    1 - however i would gladly provide all details immediately for two sites currently having the issue if this would help you in any way with your updated fix.

    Due to your errors log, I just need to update some files and it should working fine. Yep, I will need to access to both sites for fixing it :slight_smile:.

    2 - do you have a reasonable idea on time for next version with fix ?

    Actually we do having a release candidate :slight_smile:, just need some tests and we can release it in next couple days.

    Best regards,
    Hoang

  • amused

    yes i immediately sent reply to that email.
    in case you did not get that email i basically replied saying that i double checked all the info i sent and they all worked.
    i double checked the SFTP with "Transit" and "Cyberduck" and they worked.

    i mentioned in the email to make sure the first letter in the password for SFTP was uppercase and also that the port number was not 22 usually used as the default in "Transit" and "Cyberduck".
    also make sure you are using SFTP and not FTP.
    i also mentioned that you can log into my wpengine admin to see and change SFTP if needed.

    i will check back my email for details sent and try back all login details to verify again for you.
    also will resend reply email.

  • amused

    Hi @Hoang Ngo
    i installed your file and basically activated all add ons for both "Jobs and Pros" and "Private messaging" - except "Group Conversation (Beta)" because its beta.

    no problem with "bbpress integration" !!!
    i tried out the messaging with two users switching between browsers to see how each would behave and its a really nice feature and addition to bbpress.

    however i think i may have made a booboo :slight_smile:
    i installed your file while i already had 1.0.1.7 installed and activated.
    i don't know if thats the reason i got the following error (screenshot).
    but when it occurred to me i then deactivated and deleted 1.0.1.7 and installed your file again.

    but all seems perfect on my end !!!

    i just have one issue with using "Private Messaging" - bbpress integration together with "Jobs and Pros" messaging integration.

    when i got the message from bbpress (lovely live pop up BTW !!!) and clicked on view message,
    it took me to the "inbox" icon in "Jobs and Pros".

    I love how "Jobs and Pros" has its own "inbox" icon for collaboration and messaging,
    but its confusing and unsightly if a user has to jump from forums to there and see all the other "Jobs and Pros" icons that may not have anything to do with that user who is focused in the forums.
    this may not be a direct developer issue but just thought i would mention it and i would bring it up in the forums or give it some more thought to see how i can arrange the icons, short codes etc. to make it more separate and user-friendly.

    OH,
    i saw a new extra add-on in "Jobs and Pros" :slight_smile:
    i remember requesting this ;
    https://premium.wpmudev.org/forums/topic/payment-for-jobs-and-experts

    AMAZING !!

    opps, did i spill the beans ? :slight_smile:

  • Hoang Ngo

    Hi @amused,

    Many thanks for your words :smiley:. I'm very happy when hearing that.

    For your issue, Please add this code to your theme functions.php or use mu-plugins

    add_filter('je_buttons_on_single_page', 'je_buttons_on_single_page');
    function je_buttons_on_single_page($shortcode)
    {
        return '';
    }

    This will make the Inbox Page without J&E icons.

    If you have any issues please don't hesitate to let us know so we can assist

    Best regards,
    Hoang

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.