jobs & experts WYSIWYG removes my styles

for some reason when my client enters any additional styling into the jobs & experts WYSIWYG the styles are removed from the post display.

For example:
<h2><span style="color: #0000ff;">Camp University Community Liaison</span></h2>
<span style="color: #0000ff;">POSTING DATE:</span> February 17, 2017

Becomes
<p>Camp University Community Liaison
POSTING DATE: February 17, 2017</p>

The <h2> turned into a <p> and the <span> elements are missing.

Is there a way to stop this from happening? Is there a reason WHY this is happening?
Thanks!

Here's a link to the page in question - http://nusd.org/job/camp-university-community-liaison/

  • Todd Walker

    I just noticed the code i pasted above actually turned into styling.. Here's the code again.

    <h2><span style="color: #0000ff;">Camp University Community Liaison</span></h2>
    <span style="color: #0000ff;"><strong>POSTING DATE:</strong></span> February 17, 2017

    Turns into

    <p>Camp University Community Liaison<br>
    <strong>POSTING DATE:</strong> February 17, 2017</p>

    Note the missing <span> and <h2> elements

    Thanks!

  • Adam Czajczyk

    Hello Todd,

    I hope you're well today and thank you for your question!

    I checked that on my end and I can confirm the issue. The origin of it is the fact that the plugin attempts to "sanitize" data and it seems to be a little bit "too strict" with it. As a result it doesn't even seem to respect all the formatting added by its own "Advanced text area" add-on editor.

    I think that should be considered a bug. I have reported it to the developers as a bug then and hopefully they'll be able to improve that soon.

    Kind regards,
    Adam