jQuery errors after 3.9 update

Hi All

I'm having problems with our site since the 3.9 update. We are using the Enfold theme and have a thread open on their support forum regarding this too but I wanted to find out if this is a theme issue or a WP one.

When using the drag'n'drop editor within the theme we are generating JS errors. You can see a screencast here: http://www.screencast.com/t/cHijPsP1a3sp

Any advise or even a solution would be much appreciated as we want to get the site live ASAP.

Thanks
Dan
http://boadev.co.uk/