Jquery script not working with upgrade...

I have a subsite using this script:

http://refreshless.com/nouislider/

When I upgraded WP, it ceased to work. So I downloaded the original script, loaded it and I was able to break it by pointing it to version 1.11.2 vs 1.7 (version with original script). This script is now also conflicting with a Google Map Plugin via WP-TYPES.

I have a similar issue with another script using 1.8.2.

I am loading these via enqueue and I tried the header and footer to change the sequence up. What's the best strategy to fix these scripts and then the best strategy to keep them working with future releases?

It looks like they will only play nice with the old version OR does WP not load the library source it needs? If so, what's the best strategy to get this on autopilot?

As always, thanks for your help.