js issues/css issues

Gtmetrix, with most of my plugins disabled, is now showing my site to be positive after 2 days of trying to accomplish this.
But, the google page side is still showing my site as needing work:
https://developers.google.com/speed/pagespeed/insights/?url=animebusters.org

There are still just a few .js issues that need to be handled before I start showing in the green as a base with my site. Basically, before I start doing any designing or configuring and re-adding plugins as well as my content, I need to see my site in the green on gtmetrix, yslow and google page speed for SEO reasons.

Here are the current gtmetrix results:
https://gtmetrix.com/reports/animebusters.org/9bNgmDLj

If you guys can see if you can fix the mobile js issues that are showing on the google page speed, https://developers.google.com/speed/pagespeed/insights/?url=animebusters.org, I would thoroughly appreciate it! Patrick Cohen the great sir went above and beyond in helping me get this far with my site by giving me great and absolute suggestions. I wanted to send him some cookies!! I know other staff work just as hard as he so please wpmudev staff please help...you have my permission to tinker with settings as much as possible..i will check back in an hour or so.
Thanks

  • Dimitris

    Hey there Mansoor,

    hope you're doing good today! :slight_smile:

    I can see that the reported possible optimizations in Google Pagespeed are the same for mobile and desktop viewports.

    a. Eliminate render-blocking JavaScript and CSS in above-the-fold content
    In order to make full sense of this and fine tune it using our HummingBird plugin, please have a read in this article from our blog:
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    b. Reduce server response time
    That's basically the server-side of things, as well as the caching techniques used to fetch content. As you can see in HummingBird's performance report, and I quote:

    Page generation time longer than the recommended 200ms maximum will lower your score here. Much of your page generation time has to do with your hosting provider, but there are a number of steps you can take yourself to improve this score.

    Recommendations:

    1. Install and configure a full page caching plugin like WP Super Cache or Batcache. This can substantially improve your response time for logged out visitors and search engine bots.
    2. Usually your installed WordPress plugins have the greatest impact on your page generation time. Some are horribly inefficient, and some are just resource intensive. Test the performance impact of your plugins using a plugin like Query Monitor, then remove the worst offenders, or replace them with a suitable alternative.

    Advanced Recommendations:

    1. Confirm with your host that you are running at least PHP 5.5 and OPcache is enabled in your site's PHP configuration.
    2. Install and configure an object caching plugin on your site (Redis or Memcached recommended).
    3. Ask your host if they support PHP7 or HHVM to help your PHP execute faster.

    Note that many of the major managed WordPress hosting providers provide full page caching, object caching, and more modern and optimised PHP configurations as part of their offerings.

    c. Leverage browser caching
    There's a single file reported here
    http://animebusters.org/ab/?bimber-dynamic-style=1%3Frespondjs%3Dno&ver=4.10.2
    which has no extension of the supported file types that can be cached in browser (normally these are .html, .css, .js files).
    As this is coming from the theme you use most probably, it'd be better to contact theme author about it, as it may be possible to add a .css extension to it.

    Warm regards,
    Dimitris

  • Mansoor

    A2: Dimitris good sir we've already done this. I'm using hummingbird and w3cache to configure the js scripts. And it has mostly worked. I need you guys to intricately help me figure this issue out if possible. I think it may be more than just saying turn on minification because agian ive already done that.

    B2: I will ask my host the question you provided. Also those secondary caching programs, doesn't w3cahce supplment those programs like super cache, batch cache and thus not needing them?

    C2: I will ask the theme author about this problem.

  • Dimitris

    Hello Mansoor

    a. Eliminate render-blocking JavaScript and CSS in above-the-fold content
    The issue here is that you're also using Autoptimize plugin, so the actual Minification module of HummingBird isn't being used. In order to do so, you should deactivate Autoptimize and then set up HummingBird's Minification by "rechecking files".

    This will require some extended time for testing though, as you may experiencing broken parts in your site, as long as you use the "footer" option for all assets ("footer" option is the one that removes the render-blocking issues, this article here https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/ provides a very nice head start for that).

    You can filter the assets in Minification by plugin and theme and use the "footer" options. Then review your website for any broken parts, and if there are any, revert latest changes. I know that this can be intimidating, but there's no other safe way to test your actual setup and the active plugins/theme you use.

    b. Reduce server response time
    I wasn't able to notice W3TC plugin, but yeah, this would be enough for the plugin side of recommendations. No need to also have Batcache or Super Cache.
    Just don't use duplicated modules you have activated via HummingBird (browser caching and GZIP compression). As these are also provided by W3TC, simply deactivate them in W3TC's settings and use the rest of the techniques that provides.
    As for any server-side cache mechanism, well, you'll need the cooperation of your hosting provider.

    Warm regards,
    Dimitris

  • Mansoor

    so right now my site and server does use OPCApace and is currently using php version 5.6.1.

    the biggest thing is that hummingbird, since the plugin update, is now completely synced with Google page speed in reporting whats wrong with my site.

    I need us to focus on the 2 categories in hummingbird that is still showing as bad which are:
    A: removing render blocking resources
    B: server response time

    Once these things two things are improved, as now officially reported by hummingbird, I'm sure my overall page score will reflect in google page speed as being 'good' once these two issues are fixed.

    Ultimately, the logic is simple.

    Once the base animebusters.org site is green for both mobile and desktop, on the google page speed results, I can then start picking away at the speed by adding necessary plugins and manipulating my content. But, I dont want to start adding content and plugins when my site at its base core is already showing up as being bad/poor/needing work from the google speed page.

    I'm not sure if I can explain it any better than that. If we can't make my site work by improving the above red flagged options, in render blocking resources and server response time, given that I have a SUPER POWERED dedicated server that outperforms 95% of all shared hosts, I'm going to look for a turnkey wordpress based host that'll give me the initial results I require to start building my site. I'm not sure if wpmu services would then be needed at that point.

    But I don't think my request is reaching at this point all...

    Waiting on new advisement from staff............

  • Predrag Dubajic

    Hi Mansoor,

    Glad to hear you managed to do improvements and get all the results in green zone :thumbsup:

    I do have a suggestion, during your further development you will probably see "removing render blocking resources" issue coming back.

    Google does like when files are minified and combined but it doesn't like when those combined files are too big, so if the issue does come back you should re-adjust minification settings and try removing largest files from combining with others.
    This will end up with more files but they will be smaller and you should get better results.

    Best regards,
    Predrag