modules not working

hi just installed a test site on MAMP pro.

using newest pro sites 3.5.1.2 i believe was updated today.

2 problems.

“upload quotas” modules are not keeping the values i set for the specific pro sites levels.

they keep reverting to 1mb or 100mb, very strange.

i tried unchecking and checking the “Site upload space” in net work admin no luck,

i also raised that value to very high thinking it needed to be higher than what i set in pro sites module, no luck

i restarted MAMP pro servers no luck.

i deactivated, deleted and reinstalled plugin no luck.

“Premium Plugins” & “Premium Themes” are not showing up in settings at all.

i made sure there were plugins and themes not network activated so they will show up but no luck,

i figured it was because i did not have any sub sites yet so i added one and still no luck.

can you replicate this on a new or existing install ?

kind regards.

  • Frank
    • Site Builder, Child of Zeus

    Hi,

    Same issue here. I tried to access directly via url (mysite.com/wp-admin/network/admin.php?page=psts-plugins) and got the message “You do not have permission to access this page.” (i’m network admin!)

  • amused
    • friend of Bill. W.

    lol

    normally people would open new topics.

    great to see u guys following here.

    don’t worry it will be sorted out soon,

    4.3 has them (wpmudev) busy.

    i agree there are betas etc to test before hand and this *hit in my opinion should not happen or be an excuse at all.

    but this specific issue could be outside of 4.3 it seems to me which makes it even worse !!!

    regardless wpmudev in my opinion through much blood sweat and tears is better than anything/anyone else out there.

    NOT perfect – SHAME !!!

    but at least there is a continuous supply of support / feedback here etc. from them.

    no other premium plugin/theme provider can come close.

    not excusing their short comings but just making fair comparisons in my humble opinion.

  • Dutchman
    • The Bug Hunter

    Got the same problem here. No Premium plugins and themes settings showing up to change.

    Just wanted to point it out, instead of opening a new thread with the same issue.

    Also somehow all the modules where disabled ( had something setup before and now don’t know what has been changed from a previous setup)

    I got agree with @amused this should have been tested more thoroughly before sending it out.

    It is really frustrating getting things messed up for no reason. Specially with a live site and clients.

    Anyways… still the best when it comes to premium plugins and such.

  • Ken
    • Design Lord, Child of Thor

    Hi All, well you are correct Vaughn that fixed the modules problem.

    It broke:

    1. Stripe gateway, payment just loops now. Token goes to stripe

    2. Can not create a second account it loops to the 1st accounts upgrade page.

    That is as far as I got, time to walk away?

    I really don’t have another week to see if this ever gets to production quality.

    This has been tested on clean install, no other plugins, 2015 theme. So again, out of the box Pro Sites does not work.

    Lat line of error log:

    [28-Aug-2015 17:54:02 UTC] WordPress database error Table ‘vshopsad_vshops.vS_pro_sites_stripe_customers’ doesn’t exist for query SELECT customer_id FROM vS_pro_sites_stripe_customers WHERE blog_id = 2 made by require(‘wp-blog-header.php’:wink:, require_once(‘wp-includes/template-loader.php’:wink:, include(‘/themes/twentyfifteen/page.php’:wink:, get_template_part, locate_template, load_template, require(‘/themes/twentyfifteen/content-page.php’:wink:, the_content, apply_filters(‘the_content’:wink:, call_user_func_array, ProSites->checkout_output, apply_filters(‘psts_primary_checkout_table’:wink:, call_user_func_array, ProSites_View_Front_Checkout::render_checkout_page, ProSites_View_Front_Gateway::render_checkout, call_user_func, ProSites_Gateway_Stripe::render_gateway, ProSites_Gateway_Stripe::get_customer_data

    :slight_frown:

  • amused
    • friend of Bill. W.

    all seems to be working well for me but i have not configured any payments.

    keep the feed back guys,

    i am sure it helps the developers.

    i have a few error logs in wpengine dashboard,

    are these related ?

    i split it in two screenshots to see all towards the end.

  • Ken
    • Design Lord, Child of Thor

    Hi tankbay,

    No problem with admin dashboard for me. I will be testing more tomorrow. I haven’t seen any Staff replies yet, I just going to assume they are aware there is still a big problem.

    Best,

    Ken

  • tankbay
    • WPMU DEV Initiate

    I have not configured any payments either, but it has broken my dashboard. Even if I type in the path to plugins.php manually it still goes into the Updating Sites dialogue and then back to Network Settings.

    If I go the parent site it seems OK, but on the network admin dashboard page it keeps going back to settings.

    Have you guys applied any changes that have saved to your network settings yet? Be interested to see if it affects your installs in the same way.

  • Ken
    • Design Lord, Child of Thor

    Hi Guys

    I can confirm that the modules issue has been fixed. I have had no problems with a clean install, no other plugins, etc. I am now running into Stripe gateway problems again. New issue so I am going to open a new thread on that.

    Regards,

    Ken

  • tankbay
    • WPMU DEV Initiate

    Thanks guys, I have built a new install without all the plugins installed and it looks OK (not using payment gateways at the moment.

    I suspect my issue might be related to caching plugins and server settings so will open a new thread once I know more.

    I am a little worried about trusting this for our school network now though. Hopefully critical plugins like this will be held back and tested a little more thoroughly before release in future :slight_smile:

  • tankbay
    • WPMU DEV Initiate

    Found the plugin causing the loop. It seems to be when the Multisite Privacy Plugin is installed. It was working fine before the Pro Sites upgrades however.

    I am running out of time now to track this down. Are any of you guys running both of these plugins without issues?

  • tankbay
    • WPMU DEV Initiate

    Just tried both plugins on another network and as soon as Multisite Privacy is activated the site goes into the updating screen whatever menu item is selected. I’ll head over to the threads for this plugin now, but would still be interested if any of you who have said pro Sites is fine now are using Multisite Privacy and have changed a setting or just resaved the settings page without issues?

    Thanks all.

  • Ken
    • Design Lord, Child of Thor

    Hi @tankbay,

    I haven’t installed that module yet, it was on my list of additions… I will try over the weekend on my dev site. Wish I could be more help. On another note, I have thrown everything but the kitchen sink and that module on my system and it’s running like a top.

    Have a good one.

    Ken

  • tankbay
    • WPMU DEV Initiate

    Hi Ken,

    Thanks for getting back to me. Good to hear that Pro Sites is working well now. I have tried it without prosites now and it still gets locked in a loop, so I think it must be a bug or clash with something else.

    Cheers,

    Tankbay

  • tankbay
    • WPMU DEV Initiate

    Hi Ken,

    Thanks for trying that. I think you must be right as even with all plugins deleted I still get the same problem.

    I will have to take a look at this again when I get more time as I am beginning to wonder if it might be a hosting environment issue. Odd though that it never did it before.

    Cheers,

    Tankbay

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.