just installed Appointments+ and configured, but will not make an appointment. only get a spinning

check it at hallbrookproductions.com. It created the Make an Appointment tab at the top.

  • Patrick

    Hiya @Editor

    Welcome to the forums!

    First of all, it looks like you have added the [app_monthly_schedule] shortcode twice to your page. Please delete the first instance at the top of the page.

    Second, be sure the [app_confirmation] shortcode is on that page, otherwise the confirmation form cannot load.

    If you aren't sure if the shortcodes are properly inserted on the page, simply check the "Create an Appointment Page" checkbox under "Display Settings" and save. A new page will be created with the default setup.

    You can then compare your page with the auto-created page to verify things. You can also choose to keep the new page, or trash it.

    :slight_smile:

  • pxwm

    Hi @Patrick Cohen - hope you don't mind me chipping in

    Hi @Editor - Could you please confirm if you have the 'Google calendar' settings so you are synchronising with your google calendar?

    If you have could you set the 'Integration Mode' field to 'Integration disabled', then save the settings and try making an appointment.

    This should prove if you have a conflict between A+ and your google calendar.

    If you haven't got this set up could you screenpost all your settings in your 'General' tab

    Regards
    SteveB

  • Patrick

    Hi again @Editor

    I just took a closer look at your page in the JS console in my browser, and it would appear that the problem is that your theme doesn't appear to be calling the "superfish" script correctly in the header (it's trying the load the script before the rest of the document). It also appears to be no longer supported by its authors :slight_frown:

    This is how it is currently called:

    jQuery(function(){
    	jQuery('ul.sf-menu').superfish();
    });

    But would be better called like this:

    $(document).ready(function () {
            jQuery('ul.sf-menu').superfish();
    });

    To verify this, could you temporarily switch to a default theme (Twenty-Twelve or Twenty-Eleven) to test your Appointments page?

  • Editor

    PXWM - We are not using Google Calendar for anything. And I dont believe it to be related to the "General" Settings, but have attached the screenshots you requested.

    Patrick - We are aware the VodPod Theme is sadly no longer supported. The owner likes the look and we havent found anything new that she likes so we are working around that issue.

    I did what you said and tried a different theme. No change. So I then modified the header.php file with your suggestion and tried with both themes. Again, no change. Just the spinning wheel.

    It does seem to be related to how it calls up the script that allows the client to input their information when booking the appointment time. Not sure how that all works so Im hoping someone can help figure this out. I like what the plug in can do.
    And we are only a bronze member at this time so i cannot use the live chat :slight_frown:

    What next??

  • Patrick

    I did what you said and tried a different theme. No change. So I then modified the header.php file with your suggestion and tried with both themes. Again, no change. Just the spinning wheel.

    Excellent, that eliminates theme conflict. :slight_smile:

    And your settings look fine.

    Can you now post an exact copy of the content of your make-an-appointment page? You could post it to pastebin.com, then post a link to that in a reply here.

    Also, did you test with all other plugins deactivated to rule out a possible conflict with another plugin?

  • Editor

    I deactivated ALL plug ins but the appointments plus and the WPMUDEV Dashboard. No change on the creation of appointments. It did help me to find a plug in conflict that wasnt letting the hours within the "Todays Date" to update correctly. i.e. at 3 pm it still showed you could book time at 1pm and 2pm. We no longer use that plug in so i removed it.
    As for the original problem I did notice when you click(activate) a time block that the table shifts. (see attached pics) For example, if i choose the noon time hour and click, the table adds a space below it along with shifting the 3p, 4p and 5p blocks over by one.
    Dont know if that helps but thats what I noticed.

  • Editor

    Patrick - Really? Im not so certain, because that code is what adds the following months calendar to the top of the page there. I have tried using the "General" tab under Display settings where you check the Create an Appointments page box and and have it show only the current month and the results are the same.
    To verify, I deleted the original page altogether. Removed it from the trash and started new. I kept all the defaults and had it generate a new page with only the current month. Same results.

    Frustrated...

  • Vladislav

    Hello,

    Just chiming in, I have checked the page and experienced the same thing. Upon analysing the server response, I noticed that there's some kind of inline Javascript code being appended blindly to the response (apparently, it's coming from something named Attracta). This is almost certain to break the response parsing and quite probably the reason why the little waiting circle keeps spinning. If you have a plugin that could be a culprit of such behavior, can you please try disabling it and seeing if it makes a difference?

  • Editor

    BAM!!! Vladislav gets the prize! It wasnt a plug in. But here is the resolve for anyone who may run across this:

    Attracta is the SEO tool company that is used by millions of sites. Of itself, not a problem. The add on SEO Toolbar was the issue. Removing the appropriate file fixed the issue and I was able to complete the booking of an appointment.

    Thank you very much to everyone who chimed in to help. Thats what Forums are designed to do! Very much appreciated!

    G

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.