Blank page after database restore

I recently changed hosts for an individual site. I migrated all the files via FTP and restored the database via phpmyadmin successfully, I can access wp-admin and a test post just fine - http://www.eventivist.com/our-first-blog-post/
Problem is that the main page is completely blank. I have disabled all plug-ins, installed a fresh theme, but still blank. If I change the permalinks structure from /%postname%/ to default, that same post becomes a blank page.

Thoughts? Thanks in advance

Oh and the new host that the site is on now is Godaddy shared hosting...

  • Brian Purkiss

    Switching to GoDaddy is your first problem. They're a terrible webhost.

    So to be clear, you're running a vanilla WordPress instal with no plugins?

    Go to Settings > General and check the WordPress Address and Site Address. Are they correct?

    Next, check Settings > Reading. What's the "Front Page Displays" set to?

    Also, try changing the permalink structure to anything different, and then back to normal. See if that fixes anything.

    If none of those work, check your PHP error logs and let me know what's there. If you're not sure how to do this there's some good instructions here.

    Give those a try, and then we'll re-evaluate from there.

  • hpidriver

    Switching to GoDaddy is your first problem. They're a terrible webhost.

    Yes, I know. Not my decision to switch, however.

    So to be clear, you're running a vanilla WordPress instal with no plugins?

    I restored an existing Wordpress install that already had plugins and themes installed. Once it was restored, I disabled all the plugins through wp-admin

    Go to Settings > General and check the WordPress Address and Site Address. Are they correct?

    Yes

    Next, check Settings > Reading. What's the "Front Page Displays" set to?

    I don't have that option available.

    Also, try changing the permalink structure to anything different, and then back to normal. See if that fixes anything.

    As stated, changing the permalink structures causes existing posts and pages to become blank as well.

  • Mike

    Hi @hpidriver

    We're just doing a little housekeeping to see if we have dropped the ball anywhere. We haven't replied here for over 5 months which is obviously not good enough. And I apologise for that.

    Do you still have this issue? If so then please feel free to re-open this thread and we'll try and help out. If this has been resolved then please ignore this and leave the thread closed :slight_smile:

    Cheers,
    Mike

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.