Just trying out some of the themes and when I go to replace

Just trying out some of the themes and when I go to replace the stock logo "Spirit" with an image I have and try to save it I get a message "There has been an error saving your changes". Not able to save anything. Support access has been granted.
Thanks

  • Michael Bissett

    Hey @Darrin, Michael here! :slight_smile:

    I'm seeing that this is coming up in the browser's console, both when I open the editor, and when I try saving changes:

    POST http://darr.in/_wp/wp-admin/admin-ajax.php 404 (Not Found) - jquery.js:5

    One possible reason for this would be ModSecurity rules, could you try logging into your site via FTP, and inserting this into your site's .htaccess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    Before all of the other rules contained in that file? And if that doesn't work, could you contact your host about this, and ask them if there's anything in the modsec logs around the time you were trying to make your changes?

    A different exclusion may need to be provided, but they would be in the best position to advise on what exclusion would be needed (given the configuration of the server).

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Darrin,

    Not really, I'm afraid, that's talking about a .htaccess file over in your uploads folder. Were you able to contact your host about the logs? Was their response to have you look in your cPanel logs?

    If so, then I reckon it's time for some deeper digging. In that case, could you send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include FTP log-in details (hostname, username & password)
    - Include cPanel access details (login address, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Kind Regards,
    Michael

  • Darrin

    I got a reply today from my host and they stated mod_security was blocking wp-admin so they disabled it for me.
    I am now able to save edits. So it seems to be working now.

    I did still notice in the console this error
    POST http://darr.in/wp-admin/admin-ajax.php 500 (Internal Server Error)send @ jquery.js?ver=1.11.3:5m.extend.ajax @ jquery.js?ver=1.11.3:5m.(anonymous function) @ jquery.js?ver=1.11.3:5Util.post @ upfront-util.js?ufver=1.0.4:128deleteFunc @ layout-editor.js:1348(anonymous function) @ layout-editor.js:1399j @ jquery.js?ver=1.11.3:2k.fireWith @ jquery.js?ver=1.11.3:2e.(anonymous function) @ jquery.js?ver=1.11.3:2(anonymous function) @ layout-editor.js:1193j @ jquery.js?ver=1.11.3:2k.fireWith @ jquery.js?ver=1.11.3:2x @ jquery.js?ver=1.11.3:5b @ jquery.js?ver=1.11.3:5
    Should I be concerned about this?
    Thank you

  • Michael Bissett

    Hey @Darrin,

    Glad to hear that your host made those changes, and got the ability to save changes back up and running! :slight_smile:

    On that error you mentioned, I see that it comes up when saving the changes inside of Upfront, could you try increasing the memory allocated to your site?

    The details mention a style not existing (which it does), and I'd like to see if inserting this into the site's wp-config.php:

    define( 'WP_MEMORY_LIMIT', '256M' );

    Will get things working like they should. :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.