Just upgraded to multisite - can't upoad images or plugins

I just updated to Multisite.

Now I want to install Pro Sites. When I try through WPMUDEV or manually I get a screen message saying

The uploaded file could not be moved to wp-content/uploads/2014/01.

I tried to add an image in a page editor and got the same thing.

Not sure if Permalinks is an issue or what is happening. Hope someone can help.

  • Zachary
    • The Incredible Code Injector

    In the Network Settings, make sure you have the upload limit set high enough to allow you to use the upload. WordPress' default upload limit is 2MB. You also need PHP to properly be configured to upload more.

    If that doesn't work, confirm your file permissions are correct. Via SSH, you can do this by
    ls -la
    It will return all the file permission data. Confirm it is all what it needs to be. If it is not owned by the right user/group, run the following in the WordPress root directory:
    chown -R example_user:example_group *
    This will change the owner of the files with whatever your web server's user is. Apache on Ubuntu, you can simply run:
    chown -R www-data:www-data *

  • Kevin
    • Design Lord, Child of Thor

    The only choice I had was subdomain as it was being installed on an existing installation and that is what they said.

    Here is the .htaccess data

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

  • Jack Kitterhing
    • Code Norris

    Hi there @Kevin,

    Thanks for the additional information, try this

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Thank you!

    Kind Regards
    Jack.

  • Kevin
    • Design Lord, Child of Thor

    OK. Now when trying to upload Pro Sites Plugin the screen goes blank and shows this message:

    You do not have sufficient permissions to access this page.

    -------

    When I try to upload an image to Media Library I get this message:

    The uploaded file could not be moved to wp-content/uploads/2013/06.

  • Kevin
    • Design Lord, Child of Thor

    I am new to Multisite. From the Pro Sites Plugin page I have options to install the plugin to my server address or my website address.

    If I install to my website address http://www.victorywordpressexperts.com I get:
    You do not have sufficient permissions to access this page.
    Is this because it is not the Network Super Admin site?

    If I install to server address I get my webpage with this content:
    Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.
    Registration has been disabled.

  • Jack Kitterhing
    • Code Norris

    Hi there @Kevin,

    Just to clarify was multisite setup on the IP or the domain, it should technically be setup on the domain, if not, do you have a A record for your domain for that IP?

    Could you send me network admin logins and FTP please to contact(at)wpmudev.org with the subject line Attn: Jack Kitterhing and I'll take a closer look at this for you :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.