kadingibi.com

Hello there. I like the plug-in, but the two areas in the performance section do not improve. please help me
Related screenshot link https://prnt.sc/mc0l6b

  • Adam Czajczyk
    • Support Gorilla

    Hello yasin

    I hope you're well today and thank you for your question!

    I believe you're referring to our Hummingbird plugin so I let myself assign your ticket to it. This way we'll be able to help you better, I hope you're fine with that.

    As for the issue. I'll be happy to assist you with it but I'd need to take a closer look at the site's configuration first. Would you please enable support access to the site then?

    To do this, please go to the "WPMU DEV -> Support" page in your site's back-end and click on "Grant support access" button there.

    Let me know here, please, once it's done.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello yasin

    Thank you for enabling support access.

    I checked your site and I see that one of the issues ("Leverage browser caching") is already solved so let's focus on the other one, that'd be "render blocking resources".

    This can be mostly solved with Hummingbird's Asset Optimization. It's difficult to say upfront whether it will be possible to solve it fully or just improve because it's very individual to the site but there are some things that should be done first, before we can get to it.

    Could you please start with following steps:

    1. Go to the "Hummingibrd -> Caching -> Page Cache" and clear and disable the cache there
    2. Go to Autoptimize settings and disable all the optimization options there then disable entire plugin
    3. Go to "Hummingbird -> Asset Optimization" page and clear cache and re-check files there

    The scores migh temporary drop at this moment but ignore that please. Once the files there are re-check you will want to use "Advanced mode" icon next to "Clear cache" button there to switch to advanced mode.

    In the "Advanced" mode you'll have access to additional options:

    - "combine", "move to footer", "inline" for CSS files
    - "combine", move to footer", "load after the page is loaded" for JS files

    The goal is to, simply speaking, enable as many of them as possible without breaking the site. It's a daunting task and you'll need to experiment a lot (that's why it's so important to have caches disabled while doing it) and the best way to do it is to enable just some of them, check the site if it's working fine and if it is, proceed with next ones. If it's breaking, adjust those that you just enabled until it's working again and then proceed to next files - and so on until you got as many of them enabled as possible.

    Once that's done, run performance test again with WPMU DEV CDN option disabled and then again with WPMU DEV CDN option enabled - to see which one gives better results. After as many of aforementioned options are enabled as possible (and the site's still working fine) and the decision is made on WPMU DEV CDN there, then get back to the "Hummingbird -> Cache -> Page Cache" and enable the cache back.

    You'd want the to give it some time to re-build the cache and that should together help with "Render blocking resources" issue and the overall score and preformance.

    Note please: I didn't mention enabling Autoptimize plugin back because having it enabled while HB Cache and Asset Optimization is used on site can cause some conflicts and break the site in the long run.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello yasin

    I'm not sure if I understand your last post but I think you wrote that:

    1) you don't quite understand what I wrote
    2) you asked if I can do all that for you

    Is that right?

    If yes the let me try to explain that again. I'm not able to do this all for you because I don't know your site good enough. I may not be able to see if I broke anything during the process so I may not be able to fix it after that. This is a huge risk and that is why you should do it yourself.

    Let me then give you more "step by step" instruction and I hope that helps more :slight_smile:

    I see that you have already removed Autoptimize plugin so access your site's /wp-admin and then:

    1. Go to the "Hummingibrd -> Caching -> Page Cache" and clear and disable the cache there

    2. Go to "Hummingbird -> Asset Optimization" page, click on "Clear cache" button

    3. Go to "Hummingbird -> Asset Optimization" page, click on "Re-check files" button and wait until it's done.

    4. Go to "Hummingbird -> Asset Optimization page and click on "Switch to advanced mode" icon that's on the right of "Clear cache" button:

    5. Keep that page open but also open your site (front-end) in another browser where you're not logged in to the site; then follow the steps below for each file on the list, one by one, start with the first one

    a) enable the "combine" button for the first file on the list (click on it until it becomes green(ish) instead of white)

    b) scroll the page down and "Publish Changes"
    c) in that other browser where you're not logged in
    - reload the page
    - wait a moment
    - check the site carefully to see if it's still working fine
    - if it's not: disable the "combine" option for that file (button becomes white again) and repeat steps a) - c) for the next file on the list
    d) repeat that procedure (steps a) -c) ) for all the files on the list, until the end of the list

    e) repeat entire a) - d) process for all the files but this time with "move to footer" button

    f) repeat entire a) - d) process for all the CSS files but this time with "inline" button

    g) repeat entire a) - d) process for all the JS files but this time with "Force load this file after the page has loaded" button.

    This will take time but will let you optimize the site as much as possible.

    After this is done:

    1. Make sure that "WPMU DEV CDN" button on "Hummingbird Pro -> Asset Optimization" page is enabled (it's green) and run performance test; note down the score

    2. Disable the "WPMU DEV CDN" button on "Hummingbird Pro -> Asset Optimization" page and run performance test again.

    3. Compare the score: if it's better with WPMU DEV CDN enabled, enable it; if it's worse with WPMU DEV CDN enabled, keep it disabled.

    After that go to the "Hummingbird -> Page Cache" page and enable "Page Cache".

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.