Keep getting logged out!

I have the domains used for the administration area set to "mapped domain" (I have to for plugin licensing reasons as well as WordPress embedding full URL's all the time). I think the "mapped domain" setting is causing a whole bunch of problems for my admins. They keep getting logged out in different areas of the admin! For example, when they edit a post, they get logged out and send to the login screen. Tried again and still getting logged out. I tried changing all the settings for the site from the sub-domain to the mapped domain, but no luck. I of course left Info > Domain alone and left it as the original sub-domain. The settings tab is where I changed everything. I even left the site for a couple days incase of caching and also tried many browses including Chrome's incognito. Anyone have any ideas about this or experienced something similar?

  • aecnu

    Greetings Basem,

    Wow this is totally bizarre and I cannot reproduce it on my production server nor my development server.

    But on the other hand I am using logged into the network admin dashboard --> Settings --> Domain Mapping --> The domain used for the administration area should be the "domain entered by the user"

    In addition, since logged in/logged out is controlled by cookies - this presents another direction to research as an issue.

    I admit I have never seen anything like what is happening in your screen shots nor can I reproduce it therefore making this really hard to troubleshoot.

    Have you tried standard protocol for troubleshooting? i.e. disabling all plugins (except domain mapping and multi domains if being used) and see if the anomaly persists?

    Please advise.

    Cheers, Joe

  • Basem

    I just tried deactivating al plugins, but problem persisted. BUT I think I found the problem!! :slight_smile:

    For all my sites when they map a domain, I go into the site settings under network admin and I change their Siteurl to the mapped domain instead of sub-domain. I do this because I see that this is used as a variable throughout the site, and my sub-sites do not want to ever show the sub-domain. This has never been a problem, until this site.

    What I found is that there was no slash at the end of the URL and that caused the problem!!! So I added a slash at the end of the Siteurl and no more log outs! :slight_smile: See the screenshot to see what I mean.

    Am I wrong to even change the Siteurl in the first place for my mapped domain sites? I tried asking this awhile back but got no answer. After testing it on my own, it seemed ok. Maybe someone can please, please shed any light on any implications of doing this especially in a mapped domain scenario (if any). I know never to touch the sub-domain under site > info > domain, but what about site > settings > siteurl?

    Thanks a mil @aecnu for the feedback and troubleshooting tips. I hope this helps someone!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.