Landing Page Sites Display doesn't show any of the sites

Hello,
I updated the Site Categories plugin this morning and now the Landing Page Sites Display doesn't show any of the sites (links).

The Landing Page Categories Display Page seems to be working fine. It shows the different teachers and the number of sites in each.

But when you click on a class it takes you to the Landing Page Sites Display page and it doesn't give you the list of sites (students sites) like before the update.

This happened on another school site with the same setup I have on this site.

Thanks for the help,

jayjay

  • Kasia Swiderska
    • Support nomad

    Hello jayjay,

    I tested this on my Multisite and both screens are working correctly and showing the categories and sites.
    Can you check if you downgrade to previous version it this will start to work again?

    What happen if you disable "Pretty URLs for Categories" in Sites Categories settings? Will it show sites again?

    Also would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • jayjay
    • Site Builder, Child of Zeus

    Hello Kasia Swiderska,

    sorry for the delay. I was gone for the summer. I had this same problem before and Jose (Jose) came up with a fix.

    https://premium.wpmudev.org/forums/topic/site-categories-not-adding-sites

    You were also apart of the fix, but it was a year and a half ago. I tried to follow the same instructions but it doesn't seem to work. Can you give me any help and try to get this fixed.

    There is another thread having the same issue:

    https://premium.wpmudev.org/forums/topic/sites-are-not-recognized-on-the-category-page-and-in-the-sidebar-widget

    Regards,

    Jay

  • jayjay
    • Site Builder, Child of Zeus

    Hello Predrag Dubajic,

    Here's my original thread that I started. I've copied and pasted the last comment from the other post below.

    I've also granted support access to the site. Sorry for using the other poster's thread.

    "Hi Predrag Dubajic ,

    I tried the new file. It is partially working. Here's what I have done:
    - I deleted the current Site Categories and create new ones.
    - All the sites that are currently on the network are listed in the Default Category.
    - When I go to the Landing Page all the categories are listed. They have no sites listed in them except the Default Category.
    - I click on the Default Category and it shows all the students sites and I can click on the student sites. They open in a new tab, which is perfect.
    All this works brilliantly.
    Where I'm having a problem is when go to a students site and go to the Setting -> Site Categories and try to select a category from the drop down list and it won't allow me to. It shows the None Selected option and the rest of the categories but it won't allow me to select anything except the None Selected option.

    This also happens when I try and set up a new site on registration. It shows all the teachers categories but will not let me select any of them except None Selected."

  • jayjay
    • Site Builder, Child of Zeus

    Hello Kasia Swiderska,

    Yes you can enable it. I had the text changed to Students Classes with the branding plugin. I changed it back to Site Categories.

    I disabled it because I had an issue on one of the other high school sites this morning. The students weren't able to access the registration page. When the click the register link it would take them to the login page.

    I disabled the Site Categories plugin and it solved the problem. This didn't happen on the lci.school-core.com site. I just deactivated it to make sure we didn't have an issue. I have lots of students signing up this week and next.

    Jay

  • Kasia Swiderska
    • Support nomad

    Hello Jay,

    I checked again plugin on your site and mine (I disabled it on site after testing) and it seems that HTML output is different for both sites (I mean HTML for select option on registration form) and on your site there is some script that tries to manage that select.
    Because this is live site is it possible you could make a staging copy of it so we could try to exclude which plugin is adding that script?

    kind regards,
    Kasia

  • jayjay
    • Site Builder, Child of Zeus

    Hello Kasia Swiderska,

    Sorry for the delay. I had some server issue that needed my attention these past few weeks.

    I followed the plugin conflict protocol and deactivated all the plugins on the site and then I activated the Twenty-sixteen theme.

    I'm still getting the error. I'm also getting the same error on another site that I have setup for a different school. (chinook.school-core.com)

    It is, however, working on a different site that is setup similarly to the school sites. (ywcacore.com).

    Should I still setup a staging site on another domain and see if I can recreate the problem?

    Thanks,

    Jay

  • Kasia Swiderska
    • Support nomad

    Hello Jay,

    If you can setup staging site - copy of one of those sites that plugin is not working - that would be really great. This way we can do tests and not break your live site during them.
    If you have staging site, then please send in the following via our secure contact form https://premium.wpmudev.org/contact/#i-have-a-different-question :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.