Language - po and mo files not working

Hello! I'm using the language file to effect a text change. I uploaded the .po and .mo files to appointments/languages/ and removed the original file. But it's not reading it. Have I missed something? Thanks!

  • aristath
    • Recruit

    Hello there @Emerald, I hope you're well today!

    Is this a multisite or singlesite instalation?
    What have you specified as your language on the W_LANG define in your wp-config.php file?
    What is the exact name of the file you uploaded in the languages folder?

    Please advise,
    Ari.

  • Emerald
    • Flash Drive

    My site's in english. I really just wanted to change "appointments" to "lessons" and restructure some of the sentences to reflect this change. The new files are named "appointments_en.po" and "appointments_en.mo". I put the "_en" in just to differentiate the files, but I will try taking it out now and see if that works - with just "appointments.po" and "appointments.mo".

  • Emerald
    • Flash Drive

    Here's what's in my wp-config.php file:

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
    * language support.
    */
    define('WPLANG', '');

  • aristath
    • Recruit

    :slight_smile: I'm glad I could help!

    I'll just go ahead and mark this issue as resolved.
    If you need any further assistnce then please don't hesitate to reopen this and post an update on your current status, or for new issues you can always open up a new thread. :slight_smile:

    Have a great rest of the weekend!

    Take care,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.