Latest Version 1.19 is reporting as installed as V1.18

I just ran the updater and it is installing but reports that it is version 1.18 and not the new version. Keeps asking me to upgrade.