Latest Version 4.0.4 missing Includes Folder (Warning, Fatal Error and more...)

Was upgrading from 3.2.4.3 to 4.0.4 from within dashboard and got the following fatal errors:

Warning: require_once(/home/redacted/public_html/wp-content/plugins/domain-mapping/includes/config.php) [function.require-once]: failed to open stream: No such file or directory in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 39

Fatal error: require_once() [function.require]: Failed opening required '/home/redacted/public_html/wp-content/plugins/domain-mapping/includes/config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 39

That's when I noticed 4.0.4 didn't have the "includes" folder present with version 3.2.4.3 (none of the v4's do). I fixed the above issues by uploading the "includes" folder from 3.2.4.3 and the dashboard comes back, but has the following errors at the top of the all dashboard and front-end pages on the network:

Warning: include_once(/home/redacted/public_html/wp-content/plugins/domain-mapping/external/wpmudev-dash-notification.php) [function.include-once]: failed to open stream: No such file or directory in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 45

Warning: include_once() [function.include]: Failed opening '/home/redacted/public_html/wp-content/plugins/domain-mapping/external/wpmudev-dash-notification.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 45

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 82

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 82

Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 560
  • Rone

    Also note my login page for my network now shows:

    Warning: include_once(/home/redacted/public_html/wp-content/plugins/domain-mapping/external/wpmudev-dash-notification.php) [function.include-once]: failed to open stream: No such file or directory in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 45
    
    Warning: include_once() [function.include]: Failed opening '/home/redacted/public_html/wp-content/plugins/domain-mapping/external/wpmudev-dash-notification.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 45
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 82
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 560
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-login.php on line 384
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-login.php on line 396
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 695
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 696
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 697
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 698
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 699
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 700
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 703
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 704
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 705
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 706
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 709
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 710
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 711
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 712
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/PgCache.php on line 307
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/redacted/public_html/wp-content/plugins/domain-mapping/domain-mapping.php:45) in /home/redacted/public_html/wp-includes/pluggable.php on line 875
  • Jack Kitterhing

    Hi there @Rone

    I hope you are well today and thanks for your question.

    Can you confirm that all the warnings and errors have gone now?

    3.2.4.3 to the latest version is a huge update! :slight_smile: This may have caused some of the problems, was it auto updated?

    With Domain mapping I'd recommend downloading the plugin and then manually moving across the files via FTP, as the sunrise.php file also needs to be manually updated each time you update.

    You shouldn't need to move across them files for subsequent updates (the files you moved across to get rid of the warnings). :slight_smile:

    Is it all working as expected now? Please advise.

    Thanks!

    Kind Regards
    Jack.

  • Rone

    All warnings are gone save for this site:

    http://dfw-restoration.com/

    ...but I believe its a caching issue on my end. If you can tell me if you see any errors at the top of that page that would help me out greatly!

    Other than that, everything seems to be n working order now after re-uploading the missing folders/files.

    It was in fact an auto-update. I'm not sure why but, I could have sworn we were at a point where we could auto update DM. I thought I remember one of the changelogs mentioning something along those lines, but it might have been a dream. :wink:

    If not, that's cool, I will update manually, to unsure updates don't wipe out files and folders crucial to the plugin.

    Thanks!

  • Jack Kitterhing

    Hi there @Rone

    That's great news! :slight_smile:

    Your warnings about the session start can be ignored, the fatal error was due to a missing file as you found :slight_smile:

    The headers already sent is caused by whitespace in a php file most likely within a plugin, to find this, you can use this diagram to disable plugins one by one till the warnings go, but as the warning has gone, this won't be as easy :slight_smile:

    It can be auto updated, but the sunrise.php must be updated/moved manually :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.