Leverage Browser Cashing

I can not edit the NGINX on my server nor can my hosting company. This is what they said "I am afraid that the Nginx.conf file cannot be edited on shared servers. The only way custom values can be applied under it is within Dedicated server with Root access. Setting up a code under .htaccess should enforce the Leverage browsing if set up properly."

I used hummingbird that is supposed to update the .htaccess files. I am getting this message "Your .htaccess file has been updated" However only one value changed to the 8 days that is recommended. This was for Media ONLY. Java, CSS, images are all the same.
What can I do? I am a novice at this and I do not know code? This was advertised as an easy fix?

  • Bryant

    Ask your host are they using nginx as a load balancer.

    We had this problem with our host before. They may be using apache on the server level and then nginx as a load balancer in front of the servers. IF this is the case then using a browser extension like dev tools for chrome will show that you are using nginx when your server is using apache. For this case we used the apache settings under hummingbird caching and it worked fine.

  • Nastia

    Hello Bill ,

    Welcome to WPMU DEV Community!

    Would you please clarify with your host provider if the cache is included for media types like jpeg and png?

    The "Media" withing the Hummingbird includes images, audio and video types of file. So the caching might be enabled for the images and not for audio/video and it is shown as disabled.

    Thank you Bryant for chipping in, you are right, some servers running Apache on their "base". Bill would you please clarify if this is a case with your host provider?

    Please advise,

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.