Like button, how do I get it to show on the front page?

My site is How do I show the like button on post on the front page? I used other facebook plugins before, and they have options to show the like button on the front page posts.

Also, the facebook comment doesn’t show. For example,

I have the Use Facebook for comments check box checked.

I am getting these errors:

Warning: Invalid argument supplied for foreach() in l/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_pages.php on line 421

Warning: Invalid argument supplied for foreach() in /wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_pages.php on line 422

  • DavidM
    • DEV MAN’s Mascot

    Hi kinglam and welcome to WPMU DEV!

    Currently there’s not an option to display the Like button in the front-page index listing. I’ll ask the developer to take a look at possibly getting that added.

    For the moment, it can be done by adding the shortcode to your theme’s index.php file (in the loop section of course) as follows:


    As for the error, where exactly are you seeing that error displayed?

  • kinglam
    • New Recruit

    The errors were show on the wp-admin backend. I can’t get the facebook comment to show, so, I put the other plugins, Facebook Comments, and Facebook Like & Send Button plugin back to work, and deactivated the Ultimate Facebook plugin. I am using the Social Connect plugin for login also.

    I think the concept for Ultimate Facebook plugin is good, but it comes short with features compare to other stand alone facebook plugins. My problem with the others plugins is that it seems that each one of them are loading an all.js file or other js files….

  • Vladislav
    • Dead Eye Dev


    In the latest release (v1.0.7, just released), there is an option for showing Facebook Like buttons for all posts on the home page. It is located in the plugin settings, under “Facebook Like/Send Button” section.

    As for the warnings you experienced in the admin area, they should not display anymore. However, these may have been indicative of a deeper configuration issue with your plugin setup. Can you please take a look at the plugin settings and verify that you have a) created the Facebook app, b) entered your site url in the Facebook app settings, c) that you copied and pasted the Facebook app information properly in plugin settings (under “Facebook API” section).

    Also, when all that is done (and saved), you’ll want to grant extended permissions to the app. You can do that in the second section in the plugin settings, labeled “Grant extended permissions”.

  • DavidM
    • DEV MAN’s Mascot

    Hi kinglam,

    That new version should take care of your index concern. Let us know if you’re still experiencing those other issues though. We’ll be happy to delve into those, though it does seem that it’s a matter of configuration as VeBailovity was mentioning.

    Just let us know! :slight_smile:



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.