line break woes with WordPress system emails, HTML emails and Mandrill

Hoping some of the WPMU gurus can present a solution to this complex issue… Here’s my setup:

* Half my emails are in HTML

* Half my email are sent as plain text from WP

I’m using Mandrill for processing emails. If I check the Replace all line feeds ("n") by <br/> in the message body? then the WP system emails look perfect but all my HTML emails have twice as much space.

The tedious solution would be to enable that checkbox to get perfect WP system messages and then manually edit ever single line in my HTML messages to ensure there are no extra paragraphs breaks, testing and re-testing every single message until they look right.

Or…?

Some amazing block of code I can add to my functions file?