link colors

Hi there,

hyperlinks are set by default to be orange, which is fine, however on the orange button, the text does not show unless you hover. Is there a fix for this? If I change the link color to white so it shows up on the orange box, obviously links will not be visible on the rest of the site…. If I change links to green or another color, it won’t look good on top of an orange or another colored button….

  • Div Truth
    • Design Lord, Child of Thor

    Not sure the full context of your question, I assume you have access to your CSS files if not let me know. But if you like the orange text just not for orange buttons then you could make a new rule for just those instances. If you have a link to an example I can tell you exactly where to put what code, but for now let’s try this

    In you CSS file simply select the element you want and add the rule. So if the html on you button looks something like this:

    <a href="#" id="buttonName" class="orangeButton">Button Link</a>

    Then your CSS would look like this:

    Select by the ID

    color: #ffffff;

    OR you can select by the class

    color: #ffffff;

    CSS simply follows the template:

    selector {
    attribute: value;

    Hope that helps, tried to keep it as basic of an approach as I could cause from the question I can’t tell what you may already know. Let me know if that helps or what questions you may have.

  • arrowcom
    • WPMU DEV Initiate

    Thanks Nick – sorry for the confusing question… I may have figured this out but I need to figure out how it’s working… In the theme control panel I set the link color to white and I expected it to change all links to white HOWEVER all links are still orange so I think that control panel item only referred to the button beneath the feature area on the homepage, not the entire site.

  • Kimberly
    • Champion of Loops


    Hi and Welcome to WPMUDEV Community!

    The default text is set to white, however it does seem that the visited link style is set to orange, causing it to seemingly disappear while clicking around :slight_smile:

    To fix this you can check out your theme’s style css and change your visited style to this:

    a:visited {
    color: #FFFFFF;

    a simple text search for a:visited should get you that pretty quickly :slight_smile:



  • arrowcom
    • WPMU DEV Initiate

    Thanks Kimberly,

    I will try that for the buttons but will that not change all the visited links to white? I quickly tried it out using the theme control panel and that’s what happened… Next step I suppose is to try what was suggested above to isolate the buttons.

  • arrowcom
    • WPMU DEV Initiate

    Okay folks, wondering if you can help me again now that I have a more specific question – I’ve finally done some more work on this site….

    First is the default orange button below the feature area on the home page:

    – I have the backgrounds set to the colors I want for background/hover (shades of blue) but I want the actual text to appear white all the time (even on hover). Can you point me to what elements to edit within the css stylesheet?

    Secondly, I want to change the color of all text links within the site to blue rather than orange – again, can you direct me to what I need to edit?

    I’ve tried a couple of things in the stylesheet that don’t seem to be resolving it.

    You can view my sample site here:

    The button on the contact page here seems to be doing what I want it to:


  • arrowcom
    • WPMU DEV Initiate

    Thanks Kimberly – ok changing the settings in the custom styling menu appears to work with one issue: to get my button text to show up, I need to make the links white (#ffffff), which unfortunately changes the link colour on other pages to white, making them invisible. Is there a workaround for this? When you remove the link color from the custom styling menu, it makes the links and button link text orange as the default.

  • Kimberly
    • Champion of Loops

    The theme sees both as a link, so it’s using the same color for both.

    I’m wondering if you can’t define the homepage link color in your child theme somewhere in the #inner-header-signup like:

    .current_page_item a:link,
    color: #FFFFFF

    I’m not able to confirm that is correct, I’m still looking for some more info on where to put this in the css file and how to structure

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.