Linking to the 'Home' Page

Hi WPMUDEV

I'm having a little trouble trying to link to a specific page with the Upfront Issue theme. When my site first loads, I land on this page:

This is the page in which I started customising the theme for my site. I have created a custom header which includes a logo and menu.

In my logo image, I have added a link to it and selected the little Home icon via the drop down list presented in the UF editor. This does indeed link me back to the landing page pictured above.

However, in my main navigation I have a Home link also, and when following the same instructions above to link it to the Home page (via selecting the home icon via the drop down menu) I am instead redirected to this page pictured below:

I have tried selecting other options via the "post/page" selections in the editor, but I cannot find this page listed anywhere....I don't know what I am missing. I would like this page (first image) to be regarded as the "home page" and for it to be the landing page for the site.

Thanks in advance for any help
Kind Regards

    Bojan Radonic

    Hey again Ana,

    I'm afraid that granting access won't be possible due to your site being hosted locally

    With that said I've tested few things on my sandbox site and the only time this was happening when selecting "Home Page" as the link for your menu item was if reading settings were set so your front page displays static page. To check that please go to Settings -> Reading in your WP admin and check if your front page is displaying a static page like this:

    If that's the case please set it to "Your latest posts" and check again. With that set it should link to your actually front page made with Upfront.

    Please let me know if this helps

    Cheers,
    Bojan

    Ana

    Hi Bojan,

    Thanks for providing the above suggestion. I have indeed looked into this also, and my settings are set to as per what you described above: Front Page Display is set to "Your latest Posts"

    In addition to this, I also have tested using the static page option, selecting all the pages listed there, and none of them produce that initial desired landing page as pictured in my original post....its so strange.

    -----------------------------------------------------------
    Some more info that may help you debug:
    -----------------------------------------------------------
    When I click on my logo image in the header, which - as mentioned in my original post - I created via selecting the "home" icon within UF editor, I am taken to that desired landing page of the Issue theme. This landing page displays the following URL:

    http://localhost/mywebsite/

    Comparing this to when clicking on the "Home" link in the websites main navigation, I am instead redirected to the following URL:

    http://localhost/mywebsite/index.php/home/

    It seems that the issue is coming from the varying URL's. The confusing part is that even when changing the link by editing it via Upfront, and selecting the same home icon as I did when creating the link for the logo image, it is somehow using another "home" url.

    Is there a way to somehow manually force wordpress to think the "Home" page is the URL of that in the first scenario, instead of the .... index.php/home url?

    Another thing that may help you, is that this site was made before using the Upfront, Issue theme. I have carried it over, and it originally had a "home page" before this theme. Could this be where the conflicting issue is arising? The sites original theme was one I had custom built using _Underscores as the base, and then creating my own child theme from that. Could it be something to do with the old index.php of this theme somehow 'hanging around' and thus creating the conflict?

    What confuses me the most, is that there is no reference to that Upfront Issue landing page (pictured above in original post) so that I can select it in the pages listed in wordpress......its like it is a ghost or something....

    Thanks for your continued support Bojan! =D

    Ana

    *UPDATE* ...and solution

    Hi again Bojan,
    After reading my response above, the most simplest and obvious solution jumped right out at me, I couldn't believe I didn't think of it earlier....

    What I have done is deleted the original home page link in my menu (the one that was linking to a post/page as .../index.php. I then created a new home link via the UF editor, and instead of linking it to a post/page, I just selected the home icon again, and this in fact does redirect me to that desired landing page, and consequently the url of http://localhost/mywebsite/.

    If you think this is an ok solution, I am happy to just go with it. Or if it creates me problems down the line, would be good to be aware of any of these now.....

    It would be interesting though to know what exactly this page (the Issue landing page) is labelled as, as it is not listed in the pages/posts, or issue templates...

    Sorry for all the hassle, and thanks for your help