Links and formatting not showing in posts

For some reason the new theme i am using does not show up words which are bolded or highlight where there are internal and external links – Can anybody help me fix this? I am sure it should be an easy fix.

Here is a couple of examples:

http://footballbettingguide.net/premier-league-weekend-preview-15122012/

http://footballbettingguide.net/premier-league-preview-man-utd-v-sunderland/

Also, images don’t seem to be centering despite showing like that on the admin side.

Thanks

Jon

  • Brian Purkiss
    • Smushie Pies

    It’s a simple CSS issue. Add the following to your theme’s CSS file and choose the color you want. You’ll need to use HEX code, which you can pick a color here: http://www.colorpicker.com/

    For example, #E01B6A is a shade of pink.

    .post a:link { color: #COLORHERE; }
    .post a:visited,.post a:active { color: #COLORHERE; }
    .post a:hover { color: #COLORHERE; }

    I’m looking at the images and don’t see any code that would make them center, or fail to center. How are you centering them in the editor?

  • Attrition
    • Design Lord, Child of Thor

    Hi

    Thanks for the reply

    Do i need to add the code anywhere in particular within the CSS?

    I have just pasted the following at the bottom but it doesn’t seem to have had any impact?

    .post a:link { color: #F5CA1D; }

    .post a:visited,.post a:active { color: #F5CA1D; }

    .post a:hover { color: #F5CA1D; }

    As for the images – i have just clicked on them and used the text centering button.

    Thanks

    Jon

  • Brian Purkiss
    • Smushie Pies

    You put the CSS in there incorrectly.

    This is what you have:

    div#footerlinks a {
    color:#dedede;
    display:block;
    padding:5px;
    margin-bottom:5px;
    font-size:12px;

    .post a:link { color: #F5CA1D; }
    .post a:visited,.post a:active { color: #F5CA1D; }
    .post a:hover { color: #F5CA1D; }
    }

    This is how you need it:

    div#footerlinks a {
    color:#dedede;
    display:block;
    padding:5px;
    margin-bottom:5px;
    font-size:12px;
    }

    .post a:link { color: #F5CA1D; }
    .post a:visited,.post a:active { color: #F5CA1D; }
    .post a:hover { color: #F5CA1D; }

    See the difference? You placed the CSS inside another snippet, causing it to not work.

    I don’t understand why the images aren’t centering… There simply isn’t anything in the output that is doing anything to even unsuccessfully center the images.

    Do you plan on having all images centered? If so, there’s an easy fix.

  • Brian Purkiss
    • Smushie Pies

    I did some additional poking, and unfortunately, the ideal solution cannot be accomplished with the visual editor. I find the whole thing rather strange, how the visual editor isn’t able to center your images.

    The ideal, and possibly only, solution would be to add text-align:center; to the <p> that wraps the images. But that can’t be done through the visual editor without shortcode. So let’s try this.

    Add the following to your functions.php file.

    function wpmu_center_image($atts, $content = null) {
    return '<p style="text-align:center;">'.$content.'</p>';
    }
    add_shortcode("center", "wpmu_center_image");

    That will add shortcode functionality, so wrap all of your images with:

    “img here”

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.