Listings not showing up on home page

Sorry for the basic questions – checked the docs for Directory but they are a little thin.

I’ve created a couple of listings, but they aren’t showing up on the main page (http://www.agilecafe.com/). In addition, the agilecafe.com/listings page is showing a warning error in the title.

This is with a brand-new, clean WP install and the latest Directory. I’m using the BuddyPress Corporate theme, although I tried switching to the Twenty Eleven and SimpleMarket themes with no change.

I would like to a) show the listings on the home page by default and b) not have an error message for the title of the listing page.

Thanks!

-Will

  • Kimberly
    • Champion of Loops

    Hi Will!

    Can you please tell us which error you are getting? That would be helpful here :slight_smile:

    I was able to use the theme and plugin on my test site with no erros so I’m afraid I can’t find one.

    The Theme uses a particular page template for the homepage. You’d need to modify this via a child theme if you wanted to show anything other than the default display.

    You can use the shortcodes in the Directory>Shortcodes tab and add them in ot the page template via php using the ‘do shortcode’ function. I’d be glad to help you with this if you need some guidance. Or you can create your own page for use as the homepage that shows the directory listings.

    http://codex.wordpress.org/Function_Reference/do_shortcode, you might find this helpful if you intend to try the fucntion :slight_smile:

    Best,

    Kimberly

  • will_iverson
    • New Recruit

    My understanding was that I could select a new home page in the WordPress control panel. Settings -> Reading -> Front page displays -> A static page, Front page: Listings.

    When I choose that option, all my home page shows is the static text Listings, but none of the listings show up.

    I’ve attached a screenshot with the error message. The text appearing inside the title tag is:

    <b>Warning</b>: Illegal offset type in isset or empty in <b>/home/content/60/9680660/html/wp-includes/post.php</b> on line <b>840</b>

    Agile Cafe

    I’d (obviously) like to make sure everything is working out-of-the-box before I start hacking PHP files. I haven’t touched any source.

    The theme and the Directory plugin are both from wpmudev.

    Let me know if you need any more information.

  • aecnu
    • WP Unicorn

    Greetings will_iverson,

    Thank you for your additional input, it is greatly appreciated.

    Sorry for the delay as it appears that this ticket got eaten by the ticket system and while I was doing house keeping in the back today I came across it.

    Though you had mentioned using a theme from WPMU Dev, you did not mention the name of it, could you please let me know what the name is?

    I personally have not had any issue getting the Directory plugin to work and I am using the theme that accompanies the Directory plugin itself in which you are welcome to see here on my test production server:

    http://directory.aecnuwpmu.us

    Though I am indeed using the included theme, I wanted to see what theme you are using so that I may try to replicate your reported difficulties.

    Also while you are at it could you please update to the latest release of the plugin Version: 2.1.1.7 though I personally did not experience and issue with your version, but it would be good if we are on the same page and the same version.

    Please advise.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.