locked myself out as admin....

enabled Membership for the first time, went to the register page, clicked the free economy subscribe button. Now, even though I disabled Membership, I am stuck with subscriber, not admin, access.

Since Membership is disabled, shouldn't my user record default back to admin and I see everthing in the dashboard view?

  • BobWalsh

    ok - figured out what happened, but not why it happened. In the wp_usermeta there is a record, wp_capabilities.

    in a wp w/o Membership, this value looks like this:

    a:1:{s:13:"administrator";s:1:"1";}

    in the WP I screwed up, it was:
    a:2:{s:15:"membershipadmin";s:1:"1";s:10:"subscriber";s:1:"1";}

    When it should have been:

    a:2:{s:15:"membershipadmin";s:1:"1";s:13:"administrator";s:1:"1";}

    Which I manually changed to, and now i have admin privileges again.

    As best I can figure out, Membership set me to "subscriber" as per Membership level at the bottom of my Economy Membership Level.

    "Associated Role

    If you want a specific WP role to be assigned to users on this level select it below.

    Associated Role"

    -

  • DavidM

    Hi Bob,

    Thanks for sharing your resolution, especially in detail as such. There was a restriction put in place in Membership a few versions back that would disallow adding a membership level or subscription to admin accounts in the members list for that very reason.

    I think it's still possible to do so through the bulk selection options in the members list, but it looks like you've found another possible way to do that as well.

    I'll mark this as an item the developers can take a look at as we definitely wouldn't want admins losing access to their site.

    PS. I've locked myself out of a site in a similar way with a previous version. :slight_smile:

    Thanks,
    David

  • nphough

    I'm late to this thread - but thank you so much for this information! I just did the same thing and remained locked out even after I deleted the Membership plugin. Ended up deleting the following from wp_capibilities:

    a:13:{s:15:"membershipadmin";s:1:"1";s:18:"SPF Manage Options";s:1:"1";s:17:"SPF Manage Forums";s:1:"1";s:22:"SPF Manage User Groups";s:1:"1";s:22:"SPF Manage Permissions";s:1:"1";s:15:"SPF Manage Tags";s:1:"1";s:21:"SPF Manage Components";s:1:"1";s:17:"SPF Manage Admins";s:1:"1";s:16:"SPF Manage Users";s:1:"1";s:19:"SPF Manage Profiles";s:1:"1";s:18:"SPF Manage Toolbox";s:1:"1";s:24:"SPF Manage Configuration";s:1:"1";s:10:"subscriber";s:1:"1";}

    and going back to what you listed for sites without Membership:

    a:1:{s:13:"administrator";s:1:"1";}

    Thank you!

    Reopened thread to say thanks but also thinking this might be an important update for the Plugin....

    Best

    Nicole

    http://kitchencavalry.com

  • Mason

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.