Log in and profile issue

Hi, I’m having two issues with buddypress (at least I think they’re both buddypress issues, although one could be a membership issue)

The first issue relates to when new users try and log in (hence the reason I’m not sure if this is buddypress or membership plugin related). After registering and activating their account via the link on their email verification, users are asked for an “activation key”, which is apparently different from the activation key part of the url they were sent as part of their activation link in the email. I’m noticing though that this only happens when they click on/go to the login page I set up for the membership plugin. If they click on the login link on the buddypress menu at the top of my website than the users are sent to my wp-login site and they have no issue logging in with their user name and password they created.

I looked on the forum and saw that other people had a similar issue to this, but didn’t really see any solution. One response to a similar post listed a link to a buddypress forum discussing the same issue, but no solution was given to the issue in the forum link provided. The only thing I was able to glean from all my research and searching for an answer was that this was being deemed a “core” issue by WPMU staff. But if this has happened frequently enough (which it seems it does), does anyone have a work around for it at least?? I’m also unsure why the login page I created and the buddypress login pages aren’t syncing with each other.

The second issue is that the profile page I created and the profile page on buddypress don’t seem to be syncing. If one clicks the link I have in my menu to the profile page I created, users only see a blank page. However if they go to the buddypress menu at the top of the page and click on their profile their, they are sent the their profile page. Why are these pages not syncing with each other? I’m using a buddypress enabled theme (Blogs MU by WPMU) and the membership plugin – all of which are supposed to easily work with and sync with buddypress, but I’m having a lot of trouble getting everything to seemingly integrate with each other.

Please help! Thanks!