Login Loop on Multisite Sites (Not main site)

Hey

I have a multisite setup running WordPress 3.5.1. It's a subfolder setup and I currently only have 1 additional site setup. I have the WPMU DEV Domain Mapping plugin installed and the subfolder site (maindomain.com/subsite) is now running happily from it's own domain (subsite.com).

Unfortunately as soon as I activated the domain mapping for the sub site I can no longer login to it's admin panel as I am stuck in a login loop. When I visit the login page (subsite.com/wp-admin/) I immediately get redirected to the following URL:

subsite.com/wp-login.php?redirect_to=http%3A%2F%2Fsubsite.com%2Fwp-admin%2F&reauth=1

When I enter the username and password the page refreshes back to the login page, provides no error message and clears the text boxes. I can't login at all.

I have tried the usual stuff like deleting browsing data/cache/cookies/etc and I have also tried using different browsers and computers (Windows & Mac).

I can login to the main site (mainsite.com/wp-admin/) absolutely fine and I can access all the sites to make updates. The problem only happens once I enable the plugin.

Does anyone have any advice?

Thanks,
James

  • Alexander

    Hello James,

    Ok, I can help explain what's going on here. The reason you're being directed, is because your browser has not yet authenticated on that domain. When the URL switches domains, you're going to need to login again. This is because the browser doesn't understand we're working with the same application. Security measures make sure that your cookies for site A can't speak when we're on site B. This prevents login information from being stolen.

    We provide a way around this with the Wordpress Domain Mapping plugin by allowing the admin and login areas to remain mapped on the original domain. You can take a look at these options from the network dashboard where you setup the plugin to start.

    Now, I'm not quite sure why you're not at least getting an error message on submitting the form. If you refresh the page, or visit the login URL directly, are you able to get in ok?

    Best regards, Alexander Rohmann

  • landauforte

    Hi Alexander

    Many thanks for your very detailed reply. It helped with a few questions I didn't realise I had haha :slight_smile:

    Refreshing the page (ctrl & f5, etc) doesn't do anything at all. If, however I go to the admin page of the sub site via the main domain (maindomain.com/subsite/wp-admin/) then that works fine. I have also played around with the Administration mapping option on the main Domain Mapping plugin's setting page. The only option that lets me login is "original domain" the other 2 options just leave me in the loop.

    I could leave the setting as "original domain" as this wouldn't cause any issues, however I would prefer to figure out what the problem is so I can offer the correct URL to our staff.

    James

  • Alexander

    @tripvendor,

    No it wasn't resolved. I see you had another thread open where PC was able to help with this. Feel free to open a new thread if you have any more issues.

    @landauforte,

    I'm going to mark this resolved for now, as it's been quite some time, but I can still take a look at this if you like. I remember you emailed me a while ago, but without login info. If you still need help, feel free to followup here, or respond to my reply on the email.

    Take care!