Login not works fine after force HTTPS using Domain Mapping

Hello guys!

After install Domain Mapping and do the setup to force https on login and admin pages, the new users can't log in with the correct passwords.

Making tests:

1 ) With Domain Mapping enabled and using a wordpress password auto generated the login runs;
1 ) With Domain Mapping enabled and using a new password generated by user on admin page, the login not runs;
3 ) Disabling Domain Mapping, on all situation, the login runs (on https and http);

Just to inform, my initial installation of wordpress was at http and my SSL is a standard wildcard provided by GoDaddy.

Thank you!

  • Nithin

    Hi Jefferson,

    Hope you are doing good today. :slight_smile:

    Thank you for letting us know what all test you performed, I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access or see this manual.
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Jefferson

    Nithin,

    after update of Domain Mapping plugin, others problems beginning to happening:
    - Now, the Error AH00124 is displayed on my Apache log error file.
    - When I use Domain Mapping to redirect login page to mapped domain, the sites that have no mapped domain getting a error page to login and the error AH00124 is informed after request on Apache error log.

    I am very concerned about the use of this plugin. It is he who manages a lot of important thing in the application, but does not seem to be catching on!

    I will grant access to you, but would like a detailed report of any changes made. Ok?

    Thank you.

  • Rupok

    Hi Jefferson

    Hope you had a wonderful day.

    Can you please share the Apache log file so I can forward it to our developer? I believe, he can give you best idea regarding this. Can you also turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, please paste them to a text file and attach with your reply.

    Have a nice day. Cheers!

  • Jefferson

    Rupok,

    thanks for your response. I work with debug mode ON, always. Because I'm developer too. And, the debug mode not show any error information about this on the screen.

    On Apache, the error is AH00124 and not exists nothing more to see. Anyway, the problem was solved when I setting Login Mapping as "domain entered by the user" and Administration Mapping as "domain entered by user".

    Anyway, I believe that this case can be conidered as a possible bug to be fixed!

    Thank you!

  • Rupok

    Hi Jefferson

    Hope you had a wonderful day.

    So this issue completely solved? Awesome. Thanks for sharing the workaround you followed. And definitely we will take this in consideration and mark it as bug as soon as this stars happening for all including us and we can regenerate this on our test environment.

    Is there anything else we can help you with? We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.