[Login Redirect] Login redirect plugin not working

I have installed this plugin (on a multisite) but it's not showing in the subsite's dashboard, under Settings. I have used this plugin before on another multisite without problem.

  • Adam Czajczyk
    • Support Gorilla

    Hello Ellen

    I hope you’re well today and thank you for your question!

    Have you “network enabled” it or “per site” activated? On Multisite installs there are two ways to enable this plugin:

    1) if you network-enable it on “Network Admin -> Plugins” page you will not see it in dashboards of the subsites; instead you’d want to navigate to “Network Admin -> Settings -> Network Settings” page to add your redirect URL there.

    2) if you want to use it separately on each subsite, you’d want to make sure that it’s not network enabled and instead enable it individually on the “Plugins -> All plugins” page of each of the sub-sites where you want to use it; redirect URL configuration should then show up on the “Settings -> General” page of each of the sub-sites

    Kind regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Ellen

    Thank you for follow-up.

    In order to make sure that the plugin works as expected, I just tested in on my own Multisite and I can confirm that it behaves there the way I described previously. Here's a screenshot from one of the sub-sites' dashboard, with the plugin activated on that sub-site (not network-enabled):

    I understand that this is not working that way on your setup, though. I would like to take a closer look at it then so would you mind enabling support access to the site for me?

    To do so, please go to the "Network Admin -> WPMU DEV -> Support -> Support Access" page in your site's back-end and click on "Grant support access" button there.

    Let me know once it's done, please (as I won't be notified automatically), and I'll investigate the case.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Ellen

    Thank you for granting access!

    I checked the site and I must say I’m slightly confused.

    There are 16 sites on this multisite and some of them are using mapped domain so due to the way these domains are mapped, I couldn’t access them (by the way, there’s no need to use core WP domain mapping and Domain Mapping plugin at the same time, that’s a bit of overkill but that’s a different issue – as long as it works for you there’s also no need to change it).

    I did, however, checked all the others – those without mapped domains – as I could get to their dashboards and the “Login Redirect” plugin wasn’t active on any of them. So, to test it I have enabled it on the “holiday….owdonia” sub-site and it shows up fine there, as expected.

    Please go to the dashboard of that sub-site and go to the “Settings -> General” page there, you should see it there the same way as shown on the screenshot in my previous post :slight_smile:

    Or did you enable it on one of those sub-sites that are using mapped domains and it’s not visible there? If yes, I’d need a login and password to be able to access and check them. In that case, please go to the “Network Admin -> WPMU DEV -> Support -> Support Access” page and put super-admin login and password (you can always change password later, once we’re done) in a text box below “Access active for X days” green message. Let me know once that’s done and I’ll check the site again.

    Please note: do not post any login and password in your response here! Instead, follow the way described above.

    Best regards,

    Adam

  • Ellen
    • Site Builder, Child of Zeus

    Hi Adam

    Great, I see it – I wasn’t looking there, on my other multi site, under Settings tab I have a Login redirect option, which isn’t the case with this one! No matter, I can see it now, so all good!

    Many thanks for your awesome help!

    Elle x

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.