Login session ends very soon

Hello,

since today I am not able to work on hilfe.macbay.de properly, because as soon as I try to edit a page, post or navigate through the backend, I will be kicked out of the session.

I have already disabled all plugins, but with no effect.

I have restarted the apache & nginx on the server, but still no effect.

Everytime I click on "Remember Me", but also no effect.

I have checked following articles and have implemented all good practices, but still no effect:
http://www.wpbeginner.com/wp-tutorials/how-to-fix-wordpress-keeps-logging-out-problem/

Any idea how to fix the problem?

Thank you and kind regards,
Sascha

  • Adam Czajczyk

    Hello Sascha,

    I hope you're well today and thank you for your question!

    I haven't heard of that before, though I must say I'm not a Mac user and I didn't experience anything like that on Windows. I did some research though but the only "sort of related" issue that I found is quite old (2012) and seemed to be caused by... missing favicon on site - that caused Chrome to get 404 response for the resource and save a wrong/destroy login cookie.

    Might be worth checking but I'd also check if just fully clearing browser cache and deleting all cookies helps.

    Best regards,
    Adam

  • sushling

    Hey Adam,

    thank you for your reply.

    I tried everything that could have caused the session-issue:

    - added a favicon via functions.php of the theme/child -> test
    - deactivated all plugins -> test
    - cleared browser cache, cookies and history -> test
    - rebuild vhost on hosting -> test
    (- re-activated plugins after above tests failed)

    But the problem remains. So I recorded a short screen-clip and uploaded it here:
    https://dl.dropboxusercontent.com/u/700386/hilfe-session-error.mp4

    It's probably more easy for you to see what I mean. I have also granted support-access on WPMUDEV Dashboard. Could you check from your end if you can reproduce the issue?

    Kind regards,
    Sascha

  • Adam Czajczyk

    Hello Sascha,

    Thank you for your response.

    I accessed your site and created myself an account but I wasn't able to replicate that. This however only confirms that it's not a "general" issue (I"m a Windows 10 user, tested with Firefox and Chrome) but related either to Chrome on Mac or even to your particular browser.

    I would like you to check two more things though. On your video I noticed that there are several add-ons installed in your browser. It would be great if you could check that on another Mac with Chrome (preferably the one that has not been used to access the site) if it's possible and also with your browser but with all the add-ons disabled.

    If that doesn't reveal any "add-on conflict", another thing would be to update Secret Keys/Salts. To do this, visit this page first:

    https://api.wordpress.org/secret-key/1.1/salt/

    Copy all eight lines from there and replace similar lines in the "wp-config.php" file of your site with them, then again clear browser cache and login again. If that still logs you out, I'll pass that thread to my Mac-user friends here as they'll surely be able to better assist you and possibly replicate that in order to find a solution.

    Best regards,
    Adam