Login to an add-on domain brings me to the WP login page

Having trouble with the domain mapping plugin. Everything looks good in my Multisite settings but when I try to login to an add-on domain it brings me to the WP login page
I enter credentials and get a warning:
ERROR: Cookies are blocked due to unexpected output. For help, please see this documentation or try the support forums.
I've done everything suggested to allow cookies plus my web host is telling me the plugin is the problem.
Not sure what to try next.

  • Julie

    The support tech who posted this for me after a lengthy chat was given my live site credentials to forward to someone for review...

    I have since created a staging site to work through the issues as the actual live WP site is still visible from the front end and its where I'd like it to be from a design point of view.

    Whomever responds, kindly request the new staging credentials before doing any troubleshooting. Thanks!

  • Katya Tsihotska

    Hi Julie

    Hope you had a good day!

    Thank you for creating staging site, it's very helpful for further troubleshooting.

    You can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -cPanel credentials (login URL/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Julie

    How are you today?

    I'm afraid that your staging site isn't set properly. If you go to the Network Dashboard > Sites > All sites, you'll see that there listed you live subsites, not staging. Since this, I'm not able to replicate the issue on your staging site.

    However, I've checked debug log on your live site and probably found the cause of the issue. I've found the following warnings:

    [29-Sep-2017 07:58:40 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at .../wp-content/themes/Divi-child/functions.php:17) in .../wp-login.php on line 396
    [29-Sep-2017 07:58:40 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at .../wp-content/themes/Divi-child/functions.php:17) in .../wp-login.php on line 409
    [29-Sep-2017 07:58:40 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at .../wp-content/themes/Divi-child/functions.php:17) in .../wp-includes/pluggable.php on line 914
    [29-Sep-2017 07:58:40 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at .../wp-content/themes/Divi-child/functions.php:17) in .../wp-includes/pluggable.php on line 915
    [29-Sep-2017 07:58:40 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at .../wp-content/themes/Divi-child/functions.php:17) in .../wp-includes/pluggable.php on line 916

    So it looks like your theme causes a conflict, with regards to this, I would recommend you to try to temporarily switch theme on your live site to one of the default WordPress themes (eg., TwentySixteen) and check if the issue still persists. If it still occurs, try to disable also all other plugins expect Domain Mapping and try again.

    Let us know about results, please.

    KInd regards,
    Katya

  • Katya Tsihotska

    Hi Julie

    Hope you had a great day!

    There are a couple changes that should be made for recreating multisite on another domain, like set DOMAIN_CURRENT_SITE in wp-config.php and search&replace in the database. Detailed instructions about how to do it you can find here:
    https://premium.wpmudev.org/blog/move-multisite-new-domain/

    As for Domain Mapping, if you want to use it on your staging site as well, you'd need to buy and map another domain, as the same domain name can't be mapped to more than one subsite without issues.

    If you have any additional questions please let me know and I’ll be happy to help.

    Kind regards,
    Katya