Login to Facebook not working

I've installed the plugin and everything works good except for the facebook login. I click "login to facebook" and nothing happens.

I am also using a free plugin called "add link to facebook". When I deactivate this plugin everything works fine. I do not want to lose this functionality.

How can I get both plugins to work together? I have tried both checking and unchecking the javascript box.

http://www.coachcalorie.com

Thanks

  • DavidM

    Hi coachcalorie and first off, welcome to the forums!

    I'm unable to see the plugin interface on your site so I'm guessing you've got that deactivated currently?

    In any case, could you please verify you've got your App setup properly in Facebook and your credentials for that App included in the plugin settings?

    Also, as your other plugin is likely loading javascript from Facebook it's likely you'll have to disable the loading of that script with Comments Plus. You can do that by ticking the "Skip loading Facebook javascript".

    Both of those items are illustrated here:

    Could you please have a look at that and let us know how it goes?

    Thanks,
    David

  • Vladislav

    Hello,

    Indeed, this seems to be the conflict between "Add Link to Facebook" plugin and Comments Plus, and I have managed to replicate the behavior you described on my test install. Fortunately, I was also able to fix the conflict by just toggling some options around.

    Here's what worked: the "Add Link to Facebook" plugin comes with a compatibility switch you can enable to prevent the plugin from conflicting with others. To enable this feature, go to your plugin settings, switch to "Admin" tab under "Additional settings" and check this box: "Do not include Facebook script: (In case of conflicts with other Facebook plugins)".

    Next, head over to Comments Plus plugin settings and make sure that "Pages on my website already use javascript from Facebook" box is NOT checked. You will also want to make sure that both plugins are configured to work with the same app - (same App ID and App Secret).

    After this you will also want to rebuild your cache (or turn any caching off while you test).

  • coachcalorie

    Thanks for getting back to me.

    Unfortunately, I implemented those changes, but it still doesn't work.

    I checked the box in the add link to facebook plugin.

    I unchecked the javascript box for the comments plus plugin.

    I used the API for the add link to facebook plugin for the comments plus plugin so they are both the same.

    The result:

    When I click on any of the comment tabs (wordpress, twitter, facebook, google) nothing happens at all. In addition, it still causes a styles problem with my subscribe box in the top right sidebar.

    I really at a loss

  • Vladislav

    Hi,

    Just to update, I'm currently trying to replicate the exact conditions of your site (converting one of your pages to a local theme in addition to the plugins configuration), so I can hopefully get more insight on what's exactly going on and see how to fix it. As for the subscribe box issue, it's almost definitely a CSS conflict, which should never happen and will get fixed as soon as I locate what exactly is causing it. Thank you so much for your patience.

  • Vladislav

    Hi,

    I think I figured out where the conflicts come from. The subscribe box issue was a CSS conflict, and the attached updated plugin version should have that issue resolved.

    As for the Facebook button not working, there was another Facebook initialization on your page that I overlooked last time, in your Like box widget. Could you please remove everything between (and including) <script>...</script> tags from your Like box widget? It is not needed, as you'll already have Facebook initialization code on your page.

    Next, turn off your caching, re-activate the Comments Plus with Facebook javascripts included and try it with "Do not include Facebook script: (In case of conflicts with other Facebook plugins)" setting checked in "Add Link to Facebook" plugin. Also, when testing, could you please force-refresh the page first, to get rid of any old files that possibly stuck in browser cache? You can do it by pressing Ctrl+F5 in Chrome or Firefox.

  • coachcalorie

    OK, I made the changes with the suggestions you made, and here are the results.

    -CSS conflict solved

    -Comments Plus now works, but only with W3 Total Cache Plugin turned off

    -Styling of the Wordpress comment tabs "post comment" button is not right and doesn't match twitter/facebook/google. I have tried selecting the box to use my own theme's styling, but that makes things worse as I'm unable then to see any defined tabs.

    I believe you've gotten much closer, but it's not quite perfect yet. The comments plugin works now, so that's great. That being said, can you answer these questions?

    1 - can comments plus only work with caching turned off? Caching was a major benefit to my site's speed response time. However, for some reason it's running faster at the moment with it turned off. Perhaps because of the removed javascript? In either regards, I would think it would still be faster with it turned on, so would be curious if that's even possible anymore.

    2 - the styling of the "post comment" button under the wordpress comment tab is not right. How can we get those to match up to the other 3 tabs?

    Thanks a lot for the help and sticking with this project

    Tony

  • coachcalorie

    I suddenly started receiving these errors...

    Warning: session_start() [function.session-start]: open(/tmp/sess_acb7e8b5df3b5ff059a5a9bc2eb99562, O_RDWR) failed: Permission denied (13) in /home/aps1087/public_html/wp-content/plugins/comments-plus/lib/class_wdcp_model.php on line 44

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/aps1087/public_html/wp-content/plugins/comments-plus/lib/class_wdcp_model.php:44) in /home/aps1087/public_html/wp-content/plugins/comments-plus/lib/class_wdcp_model.php on line 44

  • Vladislav

    Hi,

    Comments Plus should work with your caching plugin, but you'll want to rebuild the cache for your pages for them to co-exist.

    As for the session-related warnings, they are a server-side issue. Those can be caused either by your sessions directory is filled up (this is most likely the cause), or by lacking permissions write permissions on your sessions directory (which is quite unlikely, especially since you said they didn't show up right away). Either way, this issue will affect anything else that may use sessions on your site. You may want to contact your host to resolve this issue for you.

  • Mason

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.