Looking to remove

Looking to remove the time field from the plugin input, and also in existing events displayed in the same page. Screenshot in ticket.

  • Predrag Dubajic
    • Support

    Hi Michael,

    We're still looking into this as the request seems more complex, removing the time affects entire date formatting so we need to do some further changes to have this working properly.

    We will update you here as soon as we get some additional info from the developers.

    Best regards,
    Predrag

  • Michael
    • Flash Drive

    Thanks. Well, ideally, there would be the option for an "all day" event, which would then hide the time. This is a pretty standard feature among calendar apps. If you wanted to add someone's birthday or a deadline, for instance, it makes no sense to have a time.

  • Ivan
    • Developer

    Hi Michael !

    You can try to rename {wordpress_folder}/wp-content/plugins/bp-group-calendar/groupcalendar/bp-group-calendar.php file via FTP and upload the attached file instead of it for that.
    Note: after uploading you should remove the bp_group_calendar_installed option from {database_prefix}_options table for Single WP site or from {database_prefix}_sitemeta for Multisite.
    Also, I'll ping our developers for including these changes to the next versions of the plugin.

    Best regards,
    Ivan.

  • Michael
    • Flash Drive

    Wow, thank you so much! Yeah, I see in the file there were a lot of modifications. One thing I did catch, the activity feed notification still includes the time. I found the appropriate bgc_date_display() function call, but it looks like the boolean all_day_event is not being passed. I'm not sure where to get the value in the context of that function. Do you mind making the modification or giving me the code excerpt? Thanks.

  • Predrag Dubajic
    • Support

    Hi Michael,

    Those are notices and they won't affect your functionality in any way but I'll ping Ivan to check it out.

    You should replace define('WP_DEBUG', true); in wp-config.php with below code so instead of showing any warnings and notices to you and your members it will write them in debug.log file inside wp-content folder.

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Best regards,
    Predrag

  • Ivan
    • Developer

    Hi Michael !

    It seems it doesn't relate with this patch.

    Just to make sure no other plugin is conflicting and causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If it won't help and if you provide me with additional login credentials, I can look into it more.

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Ivan Svyrskyi"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - FTP/SFTP credentials
    host
    username
    password
    (and port if required)

    Note: Don't send any credentials via this forum because it's public forum.

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.