Looks like you need to create your new db's…

Hi,

I’ve got a problem with Multi-DB.

I read all related topics on the forum but couldn’t find the solution.

When trying to open move-blogs.php on my serveur I get this error message :

Houston, we have a problem!

Looks like you need to create your new db’s! If you’re lucky, this link still works – click me

Database Error: Unknown database ‘kahutec8’

I followed the instructions there :

https://premium.wpmudev.org/project/multi-db/

It says “Select the DB SQL link and type your database name (same name as your default WordPress DB) followed by an underscore (_)”

The name of my default WordPress DB is kahute.

So there I put kahute_

In some other places too I wasn’t sure if I had to put kahute or kahute_ (step 4 for example).

I guess the problem is about this because yes database ‘kahutec8’ doesn’t exist… The real one is ‘kahute_c8’.

I just want to be sure about this underscore before I start again the whole process.

Other question :

Is it better to set ‘localhost’, the full IP adress (let’s say ’127.0.0.1?) or just the beginning of the IP adress (’127.0.0.’:wink: ?

(Same question for db-config.php and move-blogs.php)

Best Regards,

Laurent

  • Timothy
    • Chief Pigeon

    Hey there.

    I know you may have checked and double checked but all the databases are created and entered right?

    And the DBs, username and password are also correctly entered with the appropriate port number?

    Fill in your DB Name: (same as in step 2), Your DB Username and Password, For DB Local Host enter you server IP again. If you’re using a Remote Host enter that here, if you’re not just leave it blank. Finally select the number of databases you created and click “Submit”.

    Let me know.

  • Kimberly
    • Champion of Loops

    Hi!

    Just checking in :slight_smile:

    I’m guessing that because we haven’t heard back from you that you’ve got your issue worked out via live chat or email, or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don’t miss it!

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologize in advance for any lack of communication if this ticket is being closed in error.

    Thanks for being part of the WPMU DEV Community!

    Best,

    Kimberly

  • Arom77
    • Froggy

    Hi,

    I found some time to work on this and rename all my databases without the underscore. Then I ran /wp-content/scripts/move-blogs.php

    It looks good (see capture) !

    But problem is now related to point 4 ("To start the copy process click here":wink: : when I click on "click here" it just does nothing.

    I refresh the page after a moment but there is still "table not in new db" for each and every database (see the same capture).

    Morevoer, when I want to go to kahute.com I get "error establishing a database connection".

    What shall I do now ? I'm stuck :slight_smile:

    Cheers,

    Laurent

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for this great question and a significant item to bring up.

    So if I’m correct I need to grant access to ALL the databases that was created (and not only the global one) ?

    Yes absolutely correct. All databases must have user access.

    Please advise on how you make out.

    Cheers, Joe

  • Arom77
    • Froggy

    I granted access to all databases but it still doesn’t work.

    When I go to kahute.com I get “error establishing a database connection” and when I go to /wp-admin I keep getting the same message :

    “Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the kahuteglobal database.”

    As I said before (see capture) :

    “I ran /wp-content/scripts/move-blogs.php

    But problem is now related to point 4 (“To start the copy process click here”:wink: : when I click on “click here” it just does nothing.

    I refresh the page after a moment but there is still “table not in new db” for each and every database (see the same capture).”

    Is this normal ?

    Please help, I’m totally stuck.

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Sorry to see that you are still having trouble with Multi DB.

    Is your MySQL server local or remote?

    Have you triple checked all your setting both in cPanel and in the Multi DB files?

    This may require an off forum solution, meaning staff visit to your installation if you cannot resolve this right away.

    Please advise.

    Cheers, Joe

  • Arom77
    • Froggy

    Hi Joe,

    My MySQL server is local.

    I have triple checked everything. However I found some points in your tutorial not very clear for a webmarketing guy like me (I mean I am not a developper or a sysadmin of course). So I’m pretty sure everything is OK but maybe I didn’t see an obvious mistake.

    You don’t have any idea why I keep getting “table not in new db” ?

    It’s a brand new installation so maybe it’s perfectly normal ? But if I’m correct it’s not ?

    I think it would be nice indeed if you could have someone visit my installation, I’m sure it would not take so much of your precious time :slight_smile:

    Let me know !

    Cheers,

    Laurent

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for your additional input, it is certainly appreciated.

    Please send cPanel/FTP and WordPress credentials to me aecnu (at) incsub.com and though I have two more folks in front of you, I will take a look as soon as I finish up those two.

    Be sure to include the URL to this ticket within your email:

    https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Down to one in front of you now. Sorry for the delay but I am splitting my duties between forum tickets and off forum tickets in a manner that serves members best.

    Sorry for the delay.

    I should be able to get onto it tomorrow Thursday the latest. Thank you for your patience and understanding.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    I just emailed you with the db-config.php file in which needs some major adjustments.

    Could you please proceed with the recommended changes as we continue to move forward to resolve this issue.

    Do not post that file here!

    Please email it back to me after making the applicable adjustments.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for letting me know, it is greatly appreciated.

    I have indeed received the anticipated modified file.

    I continued forward trouble shooting when I dug deep into your database files and found databases like kahute_e7 and so on as shown in my screen shot below which indeed do not exist in the db-config.php and appear not to be valid databases.

    I wanted to match them up and see where this has gone wrong but cannot find or figure out what it should be.

    I hate to say it but unfortunately I think we need a total recreation of the databases and the db-config.php file to match because these are certainly not matching and correct.

    You should use myPHPadmin to wipe them all out EXCEPT NOT kahute and restart this again. Make note if your database creation is indeed adding the sign in there which after checking the https://premium.wpmudev.org/db-tools/db_sql.php for 256 databases does not exist.

    Please advise.

    Cheers, Joe

  • Arom77
    • Froggy

    Hi,

    When looking on phpMyAdmin I didn't see databases with the sign. Anyway as you asked me to do I deleted all kahute databases (except kahute) and started again the whole process.

    Everything looks fine but then I'm stuck again on my first problem :

    1- I run move-blogs.php

    2- I click on "To start the copy process click here" (step 4)

    3- Nothing happens.

    I think I'm gonna cry.

    Laurent

  • Arom77
    • Froggy

    Well, I found the databases with the sign you’re talking about when I looked at the Privileges. But in fact the sign is here for all my other websites and they are working perfectly so I guess it’s just phpMyAdmin which adds the sign. Am I correct ?

  • Arom77
    • Froggy

    Hi again,

    I’ve just seen this topic was marked as resolved, but it’s not so I re-opened it.

    I’ve got a huge project depending on this problem to be solved. I know that you’re very busy people but if you could have a look at it today or tomorrow I would be VERY grateful :wink:

    Thanks !

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for letting us know that this has not been resolved and I found it today upon my return from a short vacation for my 111th birthday.

    I do not know why it is not moving the databases and the only thing I can think of at this moment is that the database user does not have the permissions to do this action.

    Can you please check on this please, that the database user in fact does have “All” permissions?

    Please advise.

    Cheers, Joe

  • Arom77
    • Froggy

    Happy 111th birthday :wink:

    I think I found the culprit. I checked my Apache Error Log (I’m using a VPS) and saw this :

    mod_fcgid: stderr: PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 140, referer: XXX/wp-content/scripts/move-blogs.php

    mod_fcgid: stderr: PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 141, referer: XXX/wp-content/scripts/move-blogs.php

    mod_fcgid: stderr: PHP Notice: Undefined index: table in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 61, referer: XXX/wp-content/scripts/move-blogs.php?table=copy

    I guess a developper should really have a look at this.

    Cheers

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for the additional input, it is great information and obviously your host is running the fcgi module instead of straight php which appears to be where the scripting error/tragedy is happening.

    Though one of the lead developers was in here earlier, it is obvious that we need to do a recall since this is certainly beyond my personal knowledge with the exception of not running fcgi.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Arom77
    • Froggy

    In fact I tried all 3 PHP script execution mode and the problem is the same.

    – With FCGId (my default setting) I get what I already wrote.

    – With CGI wrapper I get :

    PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 140, referer: XXX/wp-content/scripts/move-blogs.php

    PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 141, referer: XXX/wp-content/scripts/move-blogs.php

    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20090626+lfs/apc.so’ – /usr/lib/php5/20090626+lfs/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0

    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20090626+lfs/apc.so’ – /usr/lib/php5/20090626+lfs/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0, referer: XXX/wp-content/scripts/move-blogs.php?table=copy

    PHP Notice: Undefined index: table in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 61, referer: XXX/wp-content/scripts/move-blogs.php?table=copy

    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20090626+lfs/apc.so’ – /usr/lib/php5/20090626+lfs/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0

    – With Apache mod_php I get :

    PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 140, referer: XXX/wp-content/scripts/move-blogs.php

    PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 141, referer: XXX/wp-content/scripts/move-blogs.php

    PHP Notice: Undefined index: table in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 61, referer: XXX/wp-content/scripts/move-blogs.php?table=copy

    Important :

    I’d prefer not to use Apache mod_php for some reasons that would take too much time to explain here :wink:

    Cheers

  • Barry
    • DEV MAN’s Mascot

    PHP Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/kahute/public_html/wp-content/scripts/move-blogs.php on line 140, referer: XXX/wp-content/scripts/move-blogs.php

    That suggests that it isn’t keeping the connection to the db for the lifetime of the script and when it comes to free it, the connection is already lost and so you get the error.

    Can you email me through your edited move-blogs.php script so I can have a quick play on my dev site – easier to work with what you have, than try to recreate :slight_smile:?

    You can get me on barry [at] incsub dot com

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Understood about running apache mod naked. Personally I run it with suphp and suexec keeping the possible fall out from dirty deeds limited to the specific end users account only.

    I am happy to see that Barry is in on this as well.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Just touching base and thank you for getting back to us on this issue.

    Normally once the lead developer has the information, relative to log in information etc. We do not get involved.

    Hopefully he will make it back in here soon, if not I will go back after it again but from the very beginning starting with database creation and forward.

    First however, I need to give the lead developer time to make his rounds before taking a tank after what appears to need a flyswatter.

    Hopefully he will address this issue sooner then later.

    Sincerely, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for letting us know that you have returned to this issue.

    I will go ahead and send a flag over to @Barry to let him know that you have returned and hopefully he has had the opportunity to go through that file you emailed him.

    Thank you for your patience.

    Cheers, Joe

  • Arom77
    • Froggy

    Hi Joe,

    Thanks for stopping by :slight_smile:

    This topic was created 5 months ago and there’s obvisoulsy a glitch with the plugin. As I said I’m working on a HUGE project but I absolutely need Multi-DB so I hope it’s going to be fixed very soon.

    Cheers,

    Laurent

  • Barry
    • DEV MAN’s Mascot

    Hi, sorry for some reason this thread keeps going to my junk email folder.

    I’ll read through but the only errors I see so far as user account related – did you manage to email through your move-blogs.php file? I can’t see it on my laptop, but it may still be in my gmail account so I’ll look there as well just in case, but if you could send it through again then that would be great.

  • aecnu
    • WP Unicorn

    Greetings Arom77,

    I am sorry to report that Kimberly is no longer part of the WPMU DEV support staff.

    Please forward whatever email you were going to send to Kimberly or Barry to me and I will get it to him.

    You can send to me once again aecnu (at) incsub.com and I will forward ti to Barry for his FYI.

    I sincerely apologize that I could not find what the issue was when I was in there in the past and that those slashes are not in myPHPadmin of any of my 21 dedicated servers – I indeed checked in an effort to get this issue handled.

    I look forward to receiving the email you want forwarded and hopefully we can get some closure to this once and for all.

    Sincerely, Joe

  • jayvega
    • Flash Drive

    Hi Barry, Aecnu and Arom77,

    Well looks like this error makes two of us with the identical problem.

    Thought I’d start with a fresh install of WPMU just to make sure I totally understood Barry’s instructions. And, after a few goes at it, it basically I am now stumped on the same identical error as Arom77.

    Here’s my scenario:

    1) Fresh install of WPMU.

    2) Tweaked wild card DNS

    3) Tested WPMU (works)

    4) Creation of ‘home’ DB

    a. EX: CREATE DATABASE wedlov_home DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

    5) Creation of ‘global’ DB

    a. EX: CREATE DATABASE wedlov_global DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

    6) Creation of 16 DB

    a. EX: CREATE DATABASE wedlov_f DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

    7) No VIP DB

    8) Grant of all user rights for all 18 DB

    a. EX: GRANT ALL ON wedlov_f.* TO wedlov_boss@localhost;

    9) Configured ‘move-blogs.php’ per instructions

    10) Uploaded:

    a. /scripts/move-blogs.php

    b. /wp-content/db-config.php

    11) Took a coffee break, came back double, triple and quadruple checked everything.

    12) Clicked on: http://domain.com/wp-content/scripts/move-blogs.php

    And, got the same identical (basically) error as Arom77. Or, so it seems…

  • jayvega
    • Flash Drive

    Barry,

    Thanks for getting back to me.

    Here is the specific error that I am getting. Perhaps I should have opened a separate ticket.

    **********************************************

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 140

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 141

    **********************************************

    >>> What’s a home db?

    The ‘wedlov_home’ database is the original database I setup when originally installing WPMU.

    >>> Can you post / email your move-blogs.php and your db-config.php files so we can take a look?

    You bet I can! I’ve attached them to this reply.

    Let me include some additional information.

    I am using the following configuration:

    MySQL version 5.1.65-cll

    Apache version 2.2.22

    PHP version 5.3.10 CPanel

    cPanel Version 11.34.0 (build 11)

    WordPress 5 (I’ve also tried xx.)

    I’ve installed 3 times from scratch, meaning fresh installs of WPMU on two separate domains. Truly I’d like to figure out the problem myself, but seems it has eluded me.

    I am currently rebuilding the entire server and going to start over – again.

    I have created the 16 +1 database MultiDB configuration now 3 different times according to your directions and all using different DB prefixes to make sure nothing overlapped. I have double check each of the 17 databases against WordPress’s initial setup page to verify I could log into each database with the WP login name and password that I was using in both the ‘db-config.php’ and ‘move-blogs.php’ files along with my ‘wp-config.php’ file.

    This verified all 16 databases were setup correctly with both user and password. I backed-out of all 16 then installed the original WPMU on ‘wedlov_home’ as my original startup database.

    It is really nuts-and-bolts kind of stuff as you have so often indicated, so I am baffled as to the reason it seems to hang up on after copying the tables into only my ‘wedlov_global’ and then erroring out 16 times on all the other databases.

    Several times I have ‘dropped’ all the tables in ‘wedlov_global’ and tried again step 4, but again I end up with the following errors:

    **********************************************

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 140

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 141

    **********************************************

    What is interesting is that I get the double line error 17 times, over and over in a list, which corresponds to the 17 databases that I am trying to copy the tables. Each time the tables are only and I repeat, ‘only’ copied into the wedlov_global database. All the other databases are blank (no tables).

    As requested I have attached both files per your request and will surely appreciate your support on this matter.

  • Barry
    • DEV MAN’s Mascot

    Line 16 needs the first 3 parts of an IP address not localhost (see example on the line above it).

    Line 25 – unless you have a table with that name, then that is going to cause problems. Delete that line.

    Lines 38+ (to end of file) change wedlov.com to be the IP address of your server.

  • jayvega
    • Flash Drive

    Hi Barry,

    Greeting again to everyone…

    I know you’re a busy, busy guy, so much appreciated the quick response.

    From the screenshot you posted above, the move-blogs.php script says that it has moved the tables to the databases – the green text below the error messages. Can you confirm that it has done so?

    Yes, Barry, those tables have been created in the first database wedlov_global. As I mentioned, I also can drop them in PHPMyAdmin and run move-blogs.php again, and they are recreated again ‘only’ in the weblov_global database. That works – perfect. But, that is also were the problem begins. No tables are created/copied into the remaining databases from _0 to _f.

    Line 16 needs the first 3 parts of an IP address not localhost (see example on the line above it).

    Actually in my last post I left out mentioning all the variations I’ve input into all the variables in the two MultiDB setup files. Too many at this point to count. Sorry, I uploaded one of those variations. However, I’ve used the (3 parts) prior and made the change again – no improvement – same errors.

    Line 25 – unless you have a table with that name, then that is going to cause problems. Delete that line.

    I am a little confused as to why remove this line, (an explanation might be in order) however, I’ve done it – no improvement – same errors.

    Lines 38+ (to end of file) change wedlov.com to be the IP address of your server.

    Same as above, I’ve use many variations in the variables, hoping to hit gold, but still my pans been empty. Again sorry, I uploaded one of those older variations. However, I have made the change and added my IP on all lines as indicated – no improvement – same errors.

    After all the suggested changes and settings I am still bewildered with the continuing errors that repeats itself 17 times when I click on step number 4).

    **********************************************

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 140

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 141

    **********************************************

    I am uploading several additional and revised files for your review, these include:

    1) db-config.php

    2) move-blogs.php

    3) wp-config.php

    4) PHPMyAdmin User Permission Profile

    5) PHPMyAdmin Table Views

    6)

    You will find them here in the (/new file) folder: https://www.box.com/shared/mllr4th5oxi21rcmoskj

    Again Barry, I know you are busy so I am doing my best to try to track down the problem myself.

    I currently have CPanel installed and will now rebuild my system again and install Plesk Panel to see if it might resolve the problem.

    Again, much appreciated any help you can give me.

  • jayvega
    • Flash Drive

    Barry,

    Any ideas?

    I’ve installed Plesk as I indicated I would above, but looks like it is not the answer. Plesk removes root control of PHPMyAdmin so impossible to use it to create the databases repetitiously using the scripts.

    Which brings up another point about my previous CPanel problem.

    I failed to mention I also tried as an alternative creating all 16 databases + the global by manually using only CPanel. Then I assigned the user with all rights to each of the 17 databases. Tested each for connectivity using my method of using the WP install page to see if it would connect to each database – it confirmed each of the databases could be connected to using WP.

    Then ran move-blogs.php, and again… (same error)

    **********************************************

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 140

    Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/wedlov/public_html/wp-content/move-blogs.php on line 141

    **********************************************

    Again, it would copy tables into ‘only’ the global database then it would commence with 17 lines of errors as I’ve indicated above.

    Sure would like to know how so many people have gotten this running and I seem to have failed completely. -:slight_frown:

    Any suggestions? Barry? Joe? Anybody?

  • Barry
    • DEV MAN’s Mascot

    Yes, Barry, those tables have been created in the first database wedlov_global. As I mentioned, I also can drop them in PHPMyAdmin and run move-blogs.php again, and they are recreated again ‘only’ in the weblov_global database. That works – perfect. But, that is also were the problem begins. No tables are created/copied into the remaining databases from _0 to _f.

    That’s strange because the screenshot you posted says that they are in the _c database.

  • Barry
    • DEV MAN’s Mascot

    I am a little confused as to why remove this line, (an explanation might be in order) however, I’ve done it – no improvement – same errors.

    That line adds global tables, if you don’t have any then you don’t need that line. You certainly don’t have a global table with that name, so not sure why you have it there.

  • jayvega
    • Flash Drive

    Barry,

    That’s strange because the screenshot you posted says that they are in the _c database.

    Yes, actually that did happen ‘one’ time on one of my many tries. It seems to have been a fluke, because it ‘only’ copied tables into 2 of the databases ‘_global and _c’ – still left the others blank. I was never able to replicate it and ever sense it has only copied tables into _global.

    You might want to draw your attention to post: https://premium.wpmudev.org/forums/topic/multi-db-installation-errors

    Seems @hitchb is getting the same error exactly as I am getting.

    Sure might be advisable to understand why we are both getting the same error, so that it can be documented and the proper advise can be provided in the installation documentation.

  • cradmin
    • WPMU DEV Initiate

    Hello Everyone.

    I thought I would chime in. I too am having this identical problem. I have tested it with all three different variations… 16, 256, and 4096. As long as the db.php file is in place, I can not access my sites, and I can not get the “click here” link to function. My errors are identical to the ones mentioned above. I am on a rather tight time crunch, and I sincerly hope that it doesn’t take an additional HALF A YEAR to get this problem sorted out.

    Best,

    CR

  • Barry
    • DEV MAN’s Mascot

    @cradmin

    I have tested it with all three different variations… 16, 256, and 4096. As long as the db.php file is in place, I can not access my sites, and I can not get the “click here” link to function.

    Again, that suggests an issue with either your db-config.php file or your database permissions. And, as I’ve asked everyone else – can you 1) check your php error log and see if there are any database related errors in there and 2) can you post the file somewhere so we can take a look at it? :slight_smile:

    Thanks.

  • cradmin
    • WPMU DEV Initiate

    Hi,

    Thanks for your quick reply, and I apologize for the “tone” in my first post. It wasn’t needed, and it didn’t help.

    Here is a past bin of my error log…

    http://pastebin.com/dVD4P5a0

    This is a paste bin of my config. I have edited the passwords…

    http://pastebin.com/XmynSd1K

    I have switched the user to one with global privileges to do all commands. I read through the previous posts, and I changed the db-conf file to several different configurations. For server address, I have used both my dedicated IP address, 127.0.0.1, and 127.0.0., and my dedicated IP address minus the last number.

    I really don’t know what other issue I am overlooking, or why all three of us seem to be overlooking the same thing.

    If it matters, I too am on a VPS that uses Virtualmin, and for the sake of full disclosure, I am using CentOS 6, and PHP 5.

    I have also attached a database screenshot.

  • Barry
    • DEV MAN’s Mascot

    I have used both my dedicated IP address, 127.0.0.1, and 127.0.0.

    Does your server respond if you login via ssh or telnet and ping 127.0.0.1? Most server have the localhost and that IP working, but it helps to make sure :slight_smile:

    But in the examples you give it should be 127.0.0.

    Line 25 shouldn’t be there unless you have a table called mysuitebiz_global in your global database.

    Lines 27 – 54 change ” to ‘127.0.0.1’ (again assuming that IP does loop to your server – shouldn’t think why it shouldn’t).

    You have a lot of database errors for queries that look ok. Can you double check that the user you are specifying in each of your add_db_server lines authenticates correctly with the username and password, and that they have full rights to each of the databases. Once you have granted the rights, did you then flush the permissions to make sure they were set on your mysql server?

  • Barry
    • DEV MAN’s Mascot

    Thanks for your quick reply, and I apologize for the “tone” in my first post. It wasn’t needed, and it didn’t help.

    Don’t stress – it’s always annoying to come across issues and we (well I anyway) don’t take it personally as I’m usually in a worse mood than the posters :wink:

  • cradmin
    • WPMU DEV Initiate

    Oooh even quicker! Yes, I can ping. I just tried it to be sure.

    I have reset the document to 127.0.0..

    I do have a table called mysuitebiz_global. I need it for a support plugin (provided by you guys, by the way). Unless you mean that I shouldn’t have an additional one… In which case I’m confused.

    Lines 27-54 are already 127.0.0.1… Do you mean change it to 127.0.0.?

    I just rechecked the permissions, and then I ran the flush permissions command. Nothing has changed… The error log is the same as before.

    Any other ideas, or would it be helpful for me to give you some sort of admin access?

  • Barry
    • DEV MAN’s Mascot

    Lines 27-54 are already 127.0.0.1… Do you mean change it to 127.0.0.?

    No, for those lines you have ”,’127.0.0.1′ change that to ‘127.0.0.1’, ‘127.0.0.1’ – one of those is the LAN address to the db server, the other is the WAN – as the server is local, setting them to the same one is the best option so the plugin will access the same server regardless.

    Any access you want to give us would be great so we can have a quick check. I’m offline for a good part of tomorrow though (and it’s almost midnight where I am, so about to shut down) so it’ll be after I get back – alternatively our @aecnu is very good at multi-db if it would be ok for him to take a look first until I get back?

    If you use the contact form (linked to below) and mark it for the attention of myself (Barry) or Joe (aecnu) and we’ll see what we can find.

  • cradmin
    • WPMU DEV Initiate

    Thanks very much. I have sent the contact and flagged the ones you requested. I spent a good bit of time trying other configurations before I sent it (even looked up old tutorials thinking they would be a bit more idiot proof), but I’m still unable to figure this out. I simply can not see anything that would be misconfigured. Hopefully this is resolved soon. This was a setback I didn’t expect, and my project deadline is SUPER close…

    Best to all,

    CR

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    There is no magic to making this work and indeed it does work. I set up my first one two years ago when I was a beginning member and had never touched word press before.

    I set up three Multi DB’s over this past weekend for members of WPMU DEV and clients of mine, one in the same in this case, all functioning perfectly as expected.

    There is nothing wrong with the scripts or the instructions – the key is paying attention to every detail down to the smallest dot.

    I have tried to help Arom77 but at the time there was something funky going on with the database character sets or even possibly something I did not understand about the way the database was being displayed by his host – I was seeing slashes … lol

    I set these up (16 DB’s) for free for my hosting clients and (16 DB’s) free for WPMU DEV members as well. And for those Multi DB’s larger then that, since I get $80 an hour recommend tot eh client/member to hire @mark De Scande at a considerably lower rate to create the larger Multi DB installs.

    No magic, no broken scripts, it does indeed work without issues on competent hosts.

    One host this does not work on because of their platform, the last I knew is/was WP Engine. Though they are more like an application server then a host from my understanding.

    Check every detail and at the end screen, I believe step for, instead of clicking the link to refresh the screen, use the browser refresh.

    Cheers, Joe

  • cradmin
    • WPMU DEV Initiate

    I get that there isn’t magic, and I understand that the scripts aren’t broken. I also understand that it requires absolute attention (as does most of the other cumputer tasks I perform… i.e. app development, and site coding). I’m just saying that I have read the instructions multiple times, and all five times that I have attempted to do this from beginning to end have resulted in identical behavior. I have used Barry’s suggestions, and the suggestions made throughout this post. It is simply just not working for me. Whether that means I am missing something (such as a dot) or my server isn’t what you would consider “competent” I’m still unsure.

    Along those lines, is there any way a list of server requirements for Multi-DB could be given? I know that Arom 77 and I are both using VirtualMin interfaces. I am on an unmanaged VPS (I control everything), but I’m not sure if Arom77 is or not. Maybe, just maybe we both have the same configuration setting either activated/deactivated/misconfigured, and that is preventing this from working. Having a clear “this is required,” sort of statement would be helpful in diagnosing this sort of thing.

    Thanks, aecnu, for your response. I’m not sure if you were suggesting that I hire someone to do this or not, but I assure you that it would be a far away last resort. I want to be able to do this. I want to know what the problem is and how to solve it. I also really dislike the idea of purchasing the plugin to only purchase the services of someone else. I’m not at all offended about this suggestion, I’m just trying to be clear on what I’m looking for.

    I sent an email with all sorts of login information. Were you able to look at the database config and config files to see if you noticed anything whacky?

    Looking forward to replies from Barry or you!

  • aecnu
    • WP Unicorn

    Greetings Arom77 and cradmin,

    Some clarifications for you folks which I believe are in order:

    @arom77 Absolutely sir you deserve for this to be working if at all possible on your hosting platform.

    @Barry – Yes Chief there were slashes as shown in my screen shot that were in phpMYadmin: https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs#post-289170

    @cradmin Yes I was indicating that I will do/setup a 16 Multi DB for free – I do them manually and they have worked at every single attempt I have made to do it with the exception of WP Engine who from my understanding does not allow it.

    I was further indicating for databases larger then 16 DB a person that will set it up for a fee much more cost effective then I want to do the same thing do to the time and effort required and not being part of my WPMU DEV support mandate.

    I have set up three of these just this past week, I follow the instructions on the Multi DB usage page step by step, and they all work flawlessly.

    There you folks have it. If you want a 16 Multi DB I will indeed set it up for free even though that is also outside of my support mandate which I believe is being more then reasonable.

    If that is what you would like me to do – no problem let me know in the manner indicated in this post https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs#post-279492

    Just let me know.

    Cheers, Joe

    On a side note it is certain that Barry will chime back in when making his rounds.

  • cradmin
    • WPMU DEV Initiate

    Thanks Joe!

    I just sent the email, so it should be good. I made a strange request in there… I would like for you to go through the process up to the point of actually executing the script. I would rather you not perform that task, so that I can see the finished config files. I’d like to see what you have done, make a backup copy, then edit it to fit my requests… If I can’t make it change, then I’ll just upload it over, and run your copy.

    Thanks again!

  • Arom77
    • Froggy

    @aecnu @Barry

    @Barry – Yes Chief there were slashes as shown in my screen shot that were in phpMYadmin: https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs#post-289170

    Yes but after you told me you saw that slashes I recreated all databases as I said here:

    When looking on phpMyAdmin I didn’t see databases with the sign. Anyway as you asked me to do I deleted all kahute databases (except kahute) and started again the whole process.

    https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs#post-292691

    (that was 5 months ago!)

    Please help.

    Regards

  • aecnu
    • WP Unicorn

    Greetings Arom77,

    I acknowledge that sir but Barry was indeed asking about that information at that time so it was indeed accurate and I have not been back there since that I recall.

    I was not saying that things have not changed or that you have not re-done the databases, I was simply confirming that at that time it was indeed accurate and all you needed to do was mention that in fact you have repaired this item :wink:

    That is all that Barry was wanting to know in this specific case if that is still the situation and at that time indeed it was and obviously no longer applicable.

    Cheers, Joe

  • Arom77
    • Froggy

    @aecnu

    Sorry, didn’t mean to be rude, just wanted to be clear enough for Barry that those slashes maybe don’t exist anymore. But that would be great if you could check if you see those slashes again.

    But really guys, what can I do to ease the process ? Looks like I’ll be dead meat before this problem gets fixed.

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for asking and yes I received the email and I hope to get over there this week and set this up.

    Actually I thought I would have had the chance to get to it this weekend since there were a few people in front of you for off forum support but now you are next in line :slight_smile:

    Looking forward to getting your Multi DB going.

    UPDATE: Actually I just recalled and checked on the statement inside your email and it is not possible to just put up the files and not activate them – they are activated the moment I dropped them into the wp-content folder.

    If I do not install it then your site will go down too, but you will then be able to see the file setup … lol

    Please advise.

    Cheers, Joe

  • Arom77
    • Froggy

    @aecnu

    Hi Joe,

    As I guess Barry doesn’t have time to deal with my problem and I need to move forward, I wondered if it was possible that you set for me a 16 Multi DB for free ? Since you will begin from scratch maybe it will work :slight_smile:

    Please let me know,

    Best Regards,

    Laurent

    PS : I wanted a 256 Multi DB but I guess I can change quite easily in 2015 when I really need to, right ?

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Certainly I will but I will need to have credentials sent to me again aecnu (at) incsub.com so I can get in there and get the job done.

    Be sure to include admin credentials for FTP, hosting control panel, WordPress admin, and a copy of the URL to this ticket please:

    https://premium.wpmudev.org/forums/topic/looks-like-you-need-to-create-your-new-dbs

    You will be next for this job after cradmin above.

    Looking forward to getting this going.

    Sincerely, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you and received!

    Aha! I know hwy the first one may have not been noted or passed by, my computer marks it as a phishing attempt – but I do have it.

    I hope to get both of you handled before the weekend is out.

    Been super busy to include preparing for taxes etc. … lol

    Sincerely, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent and cradmin,

    After dealing with over a week of happenings and getting my taxes finished and paid :-S last weekend and went after this ticket today.

    @cradmin Your site I could not FTP into at all – it came up like it does not exist. Does your host allow port 21 connections or?

    @arom77 Your site lets me in FTP but the control panel I do not see –> what you sent me sends my into the MySQ?phpMYadmin which is not where you are creating databases etc in it? And also there appears to be another installation already present.

    Please advise.

    Cheers, Joe

  • cradmin
    • WPMU DEV Initiate

    Hi Joe!

    I’m not sure what would be causing that. I just tried the connection. Perhaps I mistyped the address… The FTP address is as follows: ftp.mysuite.biz

    Thanks!

    PS I tried to remove the http that was automatically added. If it is still present, it obviously shouldn’t be there.

  • Arom77
    • Froggy

    @aecnu

    Your site lets me in FTP but the control panel I do not see –> what you sent me sends my into the MySQ?phpMYadmin which is not where you are creating databases etc in it?

    New mail sent, I hope you have now all what you need :slight_smile:

    And also there appears to be another installation already present.

    Do you want me to delete everything on this virtual server (WordPress and databases)?

    Cheers

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for your patience and I am in and Laurent’s is next to look at and I still have not received another email from Laurent – so Laurent if you are reading this now – please send one to aecnu (at) incsub.com

    @cradmin Yours may be salvageable with a bit of polishing if the databases exist in your installation. I went through your db-config.php and made some corrections which need to continue to be carried through.

    You will see the first three lines of the file starting at line 40 is the way the rest of the lines need to be formatted to around line 4135

    The next thing is it appears you are missing the globals table as shown on lines 26 and 38 i.e. mysuitebiz_global

    I have inserted it there but you should check your tables and make sure it exists using the same user permissions as the others.

    If not then manually create the mysuitebiz_global database as applicable.

    On the other hand if you still want a 16 then no problem and we will fix it up. In any event the mysuitebiz_global database appears to need to be created.

    Please advise.

    Update: While answering this ticket I thought of a way to quickly take care of my above statement You will see the first three lines of the file starting at line 40 is the way the rest of the lines need to be formatted to around line 4135 –> I have managed to make them all how they should be and no adjustment is necessary.

    Now just check for and/or create the mysuitebiz_global database and be sure to permission it with the same user as the rest of the file.

    Let me know how it goes or if you want to wipe it? But I believe this is what you wanted to try first.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    To be 110% sure that it is working which by all appearances it is, what to do is look up the blog id for aecnu.kahute.com in the wp_blogs table within the global database and then look for the site id with tables to be present within the other databases i.e. wp_19_ which reads prefix_blogID_table

    If you find it in any of the 256 databases in your case – it is indeed working.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Laurent,

    Thank you for your posts and screen shots.

    Now in the listing in the last screen shot we can see that the subsite/blog aecnu.kahute.com is assigned blog ID 4

    So therefore among however many tables there are we need to find something like wp_4_variuostablenames

    If you can find that in one of the databases – then it is absolutely sure it is working.

    Please advise.

    Cheers, Joe

  • cradmin
    • WPMU DEV Initiate

    @joe

    Thanks very much! I’m glad to hear you have made so much progress this morning! Your, sir, are awesome!

    I created the databases. I previously had removed them to try and save you a few steps. I also recreated the _global database.

    Now, for the not so great news. I tried running the script: http://mysuite.biz/wp-content/scripts/move-blogs.php It still doesn’t do anything when I click the button.

    What is the next plan? :slight_smile:

  • cradmin
    • WPMU DEV Initiate

    Ok, upon looking a bit further, I come up with this…

    First, my home page is not a good test. I use Cloudflare and a CDN, so the home page pretty much always works anyway. If I visit the admin side, http://mysuite.biz/wp-admin, I get this message:

    Error establishing a database connection

    If your site does not display, please contact the owner of this network. If you are the owner of this network please check that MySQL is running properly and all tables are error free.

    Could not find site mysuite.biz. Searched for table wp_blogs in database mysuitebiz. Is that right?

    What do I do now? Read the bug report page. Some of the guidelines there may help you figure out what went wrong. If you’re still stuck with this message, then check that your database contains the following tables:

    wp_users

    wp_usermeta

    wp_blogs

    wp_signups

    wp_site

    wp_sitemeta

    wp_registration_log

    wp_blog_versions

    I’m a little confused as to why it would still be trying to read from the old database anyway. Not sure if that matters.

    When I click the link in move-blogs.php, the address does change now. it becomes http://mysuite.biz/wp-content/scripts/move-blogs.php?table=copy

    The problem is that, once refreshed, the right column doesn’t change status, and I get the database connection errors on every blog.

    I had to change the name of dp.php back to db.php.check.I have a client scheduled to look at the site.

    Please have a look, and feel free to change what is needed.

    Thanks very much!

  • aecnu
    • WP Unicorn

    Greetings Laurent and cradmin,

    @arom77 In your case I changed all the IP’s to Local Host.

    @cradmin Your installation obviously requires more digging into in which case as you seen I made a ton of changes to your original db-config.php file but I had not checked the move file yet awaiting the reply that you created the mysuitebiz_global database with user name mysuitebiz applicably permissioned for said database.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for baring with me until I managed to get back into your installation there regarding Domain Mapping.

    I had quite the surprise today when visiting and expecting to see 4096 databases plus the mysuitebiz_global database that needed to be created and it was obviously much different and do not match my original configuration.

    How many databases do we have there now? Certainly not the original 4096?

    What are we working with there because I have everything configured to 4096?

    Please advise.

    Cheers, Joe

  • cradmin
    • WPMU DEV Initiate

    Hi Joe.

    I’m not really sure what you are talking about. I used the Multi-DB instructions… The link for the database creator… I used the 4096 database setting, and then I manually created the global database. There are other website databases on the account, but none that start with mysuitebiz_

    I don’t really know what is different… I am unaware of any changes that were made since your login other than the one that you requested.

    What would you like me to do?

    Thanks.

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for the addition input and indeed after going into your php admin for the first time ever I found the databases as described (screen shot below) and if you are not aware that is totally bizarre.

    Please advise.

    Cheers, Joe

  • cradmin
    • WPMU DEV Initiate

    I thought these were the orignal databases. I’m sure that I am missing a detail in what you are saying, but I can’t, for the life of me, figure out what is wrong with the picture. Those databases are the ones that I created with the tool from the Multi-DB plugin page. They were created using the 4096 setting.

    What is it supposed to look like? I did create those databases, but I am pretty sure I did it before you started working on my site.

    If you need me to delete the databases, I will do so, or you can do so using the account I gave you.

    I just don’t know what you need from me. The only database under Mysuitebiz that is populated is the master one. Everything else is empty.

    I am not sure what else to tell you. I am back home from the office, so I should be able to respond. It is difficult to get much done the second half of the week due to my schedule.

    Thanks,

    CR

  • cradmin
    • WPMU DEV Initiate

    Hi.

    I don’t know what is wrong with the picture you attached. I created those with the tool provided on the Multi-DB plugin page, but I think I did so before you started working on my site.

    If I need to, I will delete those, and allow you to do what you need to do.

    I am not sure what information you need from me, so I’m not sure how to help you, help me…

    I’m sorry! I should be able to respond now. The second half of my week is difficult to work around due to scheduling.

    Please let me know what I can do.

    Thanks,

    CR

    PS… I don’t know why this errored out, but it resulted in two posts… Sorry about that!

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for the additional input and clarification.

    Just a heads up that I am on this today and everything is looking good so far.

    I will touch base with you before close of business and let you know where we are at with this off forum installation.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings cradmin,

    Thank you for your patience while I dug into this and I admit I am stumped as to what is going on with the hosts configuration.

    In my screen shot above I show the databases, and you have them all – I went through the other pages in phpMYadmin and found all the 4096 db's plus the global db – and you did a great job there.

    However, after visiting the hosting control panel for the first time I see it is severely limited and indeed I am familiar with Virtmin/Webmin – but it has been crippled somehow and I am guessing that it because you are not the root administrator and they have limited what you can see/use.

    The most telling problem which I do not have an answer for, is that the databases that show in your phpMYadmin DO NOT show in your control panel under databases as shown in my screen shot below.

    I knew something funky was going on there and have now figured it out.

    In addition, I did a trace on the domain and it sent it to cloudflare which having caching of any kind on a development site is shooting oneself in the foot.

    In conclusion, phpMYadmin recognizes and shows the 4097 databases, but the hosting admin does not show a single one – it is if they do not exist.

    Therefore you should contact the host and ask them what is up with this – why do the databases do not show in the control panel? Only the original DB with 48 tables are showing in the control panel

    And once that is resolved – if they can resolve it – we can move forward in getting this mission completed.

    Let me know.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.