Lost access to my subdomain sites

Hi guys,

I SOOOO hope you can help me. I enabled Domain Mapping on my multisite that had some existing sites on it. Ever since doing so I can't access them. They either provide a 404 error or it just gives me the "Nginx is installed" page

I do hope this can be recitified as I made the cardinal sin of not making a backup before installing :slight_frown:

Support access is enabled

  • Nithin
    • Support Wizard

    Hi Mike,

    I checked your website, and I was able to notice this issue. It's a bit odd, and the issue doesn't seem to be related to plugin. If you add https protocol in the subsite url, the subsitse then works fine. At the moment the subsites loads as wpmuone.websitename.com, changing the url in the browser to https://wpmuone.websitename.com, loads the website.

    Are you using any rules to direct subdomains to http? If you are making use of such rules, could please share the rules? If not, please perform a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Also, the Domain Mapping plugin hasn't been configured correctly, could you please configure the plugin. You will have to enter the following line:

    define( 'SUNRISE', 'on' );

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    Also you'll have to copy the sunrise.php from your plugin folder wp-content/plugins/domain-mapping/sunrise.php into /wp-content/sunrise.php.

    You can find the instructions in the plugin usage section:
    https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Please advise if I'm missing anything so that we could give a closer look at this. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

    • Baldafrican
      • Made in Africa

      Hi Nithin ,

      Thanks for the reply.

      I removed the line of code and file once it gave the error in hope that it would sort out the issue. I am using the really simple ssl plugin that forces the http to https.

      I THINK I may have found a potential issue; the fact that I am using the ReallySimple SSL plugin means that I don't need to force the http option in the domain mapping plugin. I have tried this and it seems to be working for now but will keep monitoring it.

    • Baldafrican
      • Made in Africa

      Hi Nithin ,

      Here are the redirect rules that are setup;

      RewriteEngine on
      RewriteCond %{HTTP:X-Forwarded-Proto} !https
      #wpmu rewritecond oceansauce.com
      RewriteCond %{HTTP_HOST} ^oceansauce\.com [OR]
      RewriteCond %{HTTP_HOST} ^www\.oceansauce\.com
      #end wpmu rewritecond oceansauce.com
      RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

  • Rupok
    • Support Ninja

    Hi Mike,

    So sorry to hear the inconvenience you are having. I tried to login with Support Access to check the issue but found that your network is down. What caught my attention is, you are using Cloudflare CDN which might be a reason behind the issue you are having, I'm not sure though.

    Can you please temporarily disable Cloudflare and check what happens? Moreover, can you please check your .htaccess file and make sure you have default code there? You will get standard default code of your .htaccess file from this page: https://codex.wordpress.org/htaccess Please let us know how it goes.

    And please let us know when your site is accessible again. We will jump in as soon as you confirm.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.