Lost connection with Luis Lupes

My connection with Luis Lupes was broken. He was in my cPanel checking a problem. What do I do now?

  • Predrag Dubajic

    Hi Neal,

    Sorry for this inconvenience with chat, unfortunately, it happens sometimes :slight_frown:

    I pinged Luis and get the login details to check your site and I was able to find the issue.

    In your wp-config.php the comment tag was not closed properly so a couple of defines are completely disabled in there, including the one for caching.

    To explain better what I'm referring to please check this screenshot:

    It seems that your define for WP debug is misplaced and there's no closing of the comment so entire code marked in that screenshot is not being applied.

    Now, I'm not sure if this was intentional and you wanted to comment out some code so I didn't enable everything.
    I did enable caching so that's sorted out, but I also moved WP debug define and added two "REMOVE THIS LINE" lines which when removed will get rest of your commented out code working again.

    Check this new screenshot of your wp-config.php file for more info:

    Let us know if you have any followup questions about this :slight_smile:

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Neal,

    These are mostly not a standard part of the wp-config.php file and are added additionally to adjust certain things.

    I wouldn't be comfortable enabling or removing any of those until I explain what they do, so you can check if they are added there on purpose.

    define( 'WP_DEBUG', false ); - This one is preventing WP to show any errors on the frontend and to your visitors, this is ok to be enabled and set to false.

    define( 'AUTOSAVE_INTERVAL' , 300); - When you edit your posts/pages WP saves the changes automatically every 60 seconds, with this define you are increasing it to save on every 300 seconds.

    define( 'WP_POST_REVISIONS' , 5); - With this you define how many post revisions WP will save.

    define( 'EMPTY_TRASH_DAYS' , 7); - When you trash your posts or pages, WP will store them in trash for 30 days, with this define it will remove it after 7.

    define( 'WP_CRON_LOCK_TIMEOUT' , 120); - This define sets how often a Cron job can be performed and makes sure it doesn't happen multiple times under a set time. By default it's set for cron process to be able to run per minute and with this you're changing it to be per 2 minutes.

    Please check what do you need from these and if you need them all you can simply remove the two lines mentioned in my previous comment and that's it :slight_smile:

    Best regards,
    Predrag

  • neal_umphred

    PREDRAG

    1. My apologies for the delay in responding, but I fell asleep.

    2. Thanks for going though this for me.

    3. I would like to keep define( 'WP_DEBUG', false ); and change the following to their original default settings:

    • Change define( 'AUTOSAVE_INTERVAL' , 300); back to 60 seconds.
    • Change define( 'WP_POST_REVISIONS' , 5); back to ?.
    • Change define( 'EMPTY_TRASH_DAYS' , 7); back to 30 days.
    • Change define( 'WP_CRON_LOCK_TIMEOUT' , 120); back to 60 seconds.

    How do I do this?

    NEAL

  • Adam Czajczyk

    Hello neal_umphred

    Thanks for your response!

    In that case, please

    1. remove the "REMOVE THIS LINES" lines as marked on that Predrag's screenshot in this post:
    https://premium.wpmudev.org/forums/topic/lost-connection-with-luis-lupes#post-1313959

    2. Simply remove these lines from the file:

    define( 'AUTOSAVE_INTERVAL' , 300);
    define( 'WP_POST_REVISIONS' , 5);
    define( 'EMPTY_TRASH_DAYS' , 7);
    define( 'WP_CRON_LOCK_TIMEOUT' , 120);

    This way you'll keep the debug line with debugging turned to false and also turn the other 4 options to their default values which are:

    - 60 seconds for AUTOSAVE_INTERVAL (meaning that posts will be saved every minute)
    - indefinite number of WP_POST_REVISIONS (by default WP stores all revisions)
    - trash emptied every 30 days
    - WP Cron triggered every minute.

    Best regards,
    Adam