lots of errors showing up when activating BP Group email

please find attached screenshot,
lots of errors showing up when i activate BP Group Emails.
shows up in network admin, main site admin as well as front end.
any kind assistance in this would be greatly appreciated.

its a simple but very powerful and convenient plugin thats great to keep installed.
would love to have it working properly.

support access granted if needed.
kind regards.

  • amused

    yes indeed strange its working good here now as well.
    was having the same issue with pro sites i mentioned on another thread,
    please allow me to explain.
    so basically if i activate the plugin with php 7.0.3 i get lots of errors and instability.
    when i deactivate the plugin with php 7.0.3 all is well.
    so i tried leaving the plugin activated with all the errors and switching to php 5.6.18 and it worked fine.
    so this basic trouble shooting led me to believe it was the plugin not being able to work with php7
    HOWEVER !!!
    there was buddy press, bbpress, and quite a few other buddy press plugins as well on the site.
    when i deactivate them all and leave pro sites, bp group email, and a few other wpmudev plugins activated, they all work fine with php7
    so i am thinking that maybe to many plugins with php7 may be causing an issue or possibly a conflict of plugins ONLY with php7
    i guess i will have to keep testing :slight_smile:

    thanks again for your support in this and please don't hesitate to provide any kind suggestions and feed back.

  • amused

    hi @luiscarloslopes
    i did some further testing with php 7.0.4 as well.
    basically php 5.6.xx is fine by itself.
    in fact php 5.6.xx with HHVM also works fine.
    php 7.0.3 and 7.0.4 is giving lots of errors on the front end and admin.
    it does not happen by itself.
    it only happens when both BP group email and BuddyPress are both network activated.
    in fact i deactivated every plugin except wpmudev dashboard.
    only BP group email and BuddyPress network activated is giving the errors when activated together it seems.
    support access granted.

    your kind assistance in this would be greatly appreciated.

  • amused

    can i get any further advise on this ?
    i am not even sure if the site i selected originally for this post id the same because i have tried several sites/domains repeatedly (installed, deleted and installed again) and keep getting the same problem.
    i figured it was "KLEO" theme which i know is a pretty big customized theme, so even switching to a wp default theme like Twenty Fifteen etc. still causes lots of errors both in admin and front end all over the screen (as shown in screen shot above).
    i appreciate Luís testing the plugin and "it seems to work well",
    but as i mentioned i also tested with wp default theme and all plugins except buddy press deactivated and still get errors, then switch to php 5.6.19 and all is well, and as mentioned,
    this happens repeatedly deleting sites and trying on fresh installs,
    i even tried fresh installs with Softaculous as well as manual installs i created without Softaculous.
    so what else shall i try ?
    I am on SiteGround 'Cloud' (not shared).
    i believe i even tried both single as well as multisite installs but if i am not to sure if my memory serves me correct with this but where the errors are occurring for certain is multisite (sub-directories).
    really nice plugin and i would love to use it with php 7.0.4 as version7 makes such a HUGE deference in speed.

    any kind assistance here would be greatly appreciated.

  • amused

    thanks for the honesty @luiscarloslopes
    this is not settled for me as i am having other issues with php 7 on SiteGround that works good on MAMP PRO and CloudWays with php 7
    but the point is that "BP group email" definitely has issues with them.
    but also please note i have no issues with "BP group email" using php7 on MAMP PRO and CloudWays MAMP PRO , but rather just SiteGround.
    so to help troubleshoot,
    where/what platform are u seeing issues as well ?
    i will help all i can to resolve this in the hope it will benefit me, your plugin (BP group email) and other hosts.

    kind regards and thanks again !!!

  • amused

    I think i may have hopefully narrowed in a bit more into this !!!
    It seems to be only happening with the "User Groups" - "Components" of BuddyPress.
    In other words,
    i painstakingly activated, deactivated, every possible plugin, and every possible setting for each plugin individually until it seems to me to be only happening when under Network Admin (multisite - super admin) - Settings/BuddyPress/Components .
    Then only when the "User Groups" are ticked and saved then all the SH*T hits the fan !!!

    I have reported this more than 5 months ago !!!
    can whatever the issue be implemented in an update ?

    I love trying out every possible Host and honestly i can tell you that this is happening currently on ServerPilot as well as a couple other popular hosts.

    so in my logical view of trouble shooting i do not think this is unique to me and would much appreciate that this be addressed.

    your very kind assistance in this would be much appreciated.
    kind regards !!!

  • amused

    thanks for your reply here Luís
    Yes as i mentioned above your "temporary hotfix" works perfectly.
    i do not see any errors when i use the file you provided.
    my comments above about "only when the "User Groups" are ticked and saved" was just some extra troubleshooting i did to hopefully help in some way.
    and yes i totally assumed that the fix would be applied to your official release seeing that there clearly is an issue.
    thanks again for all your kind assistance and support in this.
    much appreciated.
    BLESS !!!