Lots of warnings due to the plugin

Hello,

I get a lot of errors at /wp-admin/customize.php page (what ever theme I use, even default). And these errors are shown even despite the fact I have DEBUG false in config.php

As 3 of 4 errors are due to WP - they are the consequence of the error connected with the plugin. Help me fix it pls.

WP 4.0.
P.S.- I am not authorised to give access, sorry.

  • Vinod Dalvi
    • WP Unicorn

    Hi Eugene,

    Sorry to hear of the problem you are having.

    I have tested on my test sute using default WordPress theme Twenty Twelve and latest version of Multisite Privacy plugin but didn't get any warning message even when i set wp debug on as displayed in the attached screenshot.

    This can also be due to plugin/theme conflict.

    You can just try on your development site using default WordPress theme like Twenty Thirteen and deactivating all other plugins as displayed in the flowchart on the following page to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Kind Regards,
    Vinod Dalvi

  • Eugene
    • The Incredible Code Injector

    I deactivated all plugins at the sub-site and changed theme (several times). And it seems to me that there are 2 problems:
    1) with WP.
    2) with the plugin "Multisite Privacy".

    Watch the screenshot. Pls ask the plugin developer take a look at the issue.

  • calvinrogercanas
    • New Recruit

    Hello @Eugene

    Hope you're well today! :slight_smile:

    If the warnings are not affecting your install, I would suggest that you hide them(if it is turned on) by editing your php.ini then find display_errors = On (around line 277) and change it to display_errors = Off.

    Like my co-worker, I tested this on one of my test site but can't reproduce the warnings. Since you can't provide access there is little more we can do unless you can create a sandbox site where the issues exist and that you can give us access.

    Can you please also add this line of code to your wp-config.php. So the error will go to a file and never displayed on a screen.

    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Cheers!
    Calvin

  • Eugene
    • The Incredible Code Injector

    Bingo! I got the problem:
    If you use quotation marks (like ") in the title of the blog or description - you got the errors. For example - print this as the blog title: My "test"

    So, how could I fix it? Help me pls.

  • Eugene
    • The Incredible Code Injector

    We activated all plugins we have at a single test WP - everything is OK. But some plugins were not activated due to they need Multi Site mode... Here they are:
    Multisite Theme Manager
    New Blog Templates
    Pretty Plugins
    Pro Site
    Simple Sitemaps For Multisite
    WHMCS Multisite Provisioning

    So, the thing that cases the problem must be either in these plugins or in WP MU mode. Could you test both suggestions pls?

  • Jack Kitterhing
    • Code Norris

    Hi there @Eugene,

    Hope you're well today!

    I can confirm the warnings are from MU privacy plugin, the lead developer has been notified, in the mean time as they warnings and not errors your install will still work perfectly.

    To hide them in the mean time you the following

    ini_set('log_errors','On');
    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    In your wp-config.php above the line reading that's all stop editing happy blogging!

    Thanks!

    Kind Regards
    Jack.

  • Vinod Dalvi
    • WP Unicorn

    Hi Eugene,

    I have notified @Jack Kitterhing regarding how many Warnings he is getting and how many of them related to MU privacy plugin.

    Again i have tested on my test sute using default WordPress theme Twenty Twelve, latest version of Multisite Privacy plugin and quotation marks (like ") in the title of the blog and description even i used blog title as My "test" but didn't get any warning messages.

    @Jack Kitterhing It would be helpful if you explain how you have reproduced these warnings and share screenshot of it.

    Thanks,
    Vinod Dalvi

  • Jack Kitterhing
    • Code Norris

    Hi there @Eugene,

    Hope you're well today! :slight_smile:

    I've just done some further testing here after talking with @S H Mohanjith and after deactivating the majority of the plugins on my site I couldn't replicate.

    Can you send me the following please so I can test this on your install by disabling the other plugins.

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • Eugene
    • The Incredible Code Injector

    S H Mohanjith, none of them. I tried add some and deleted all of the widgets - nothing changed.

    Jack Kitterhing, sorry, but I am no authorised to give access. But as I see, it is not needed really as you got the errors earlier.

    Also here is some fresh info form debug.log (may be this can help some how):

    [28-Nov-2014 18:41:56] PHP Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /var/....ru/wp-includes/functions.php on line 3370
    [28-Nov-2014 18:41:56] PHP Warning: Invalid argument supplied for foreach() in /var/....ru/wp-includes/class-wp-customize-widgets.php on line 175
    [28-Nov-2014 18:41:56] PHP Warning: Invalid argument supplied for foreach() in /var/....ru/wp-includes/class-wp-customize-widgets.php on line 215
    [28-Nov-2014 18:41:56] PHP Warning: Cannot modify header information - headers already sent by (output started at /var/....ru/wp-includes/functions.php:3370) in /var/....ru/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 591
    [28-Nov-2014 18:41:56] PHP Warning: Invalid argument supplied for foreach() in /var/....ru/wp-includes/class-wp-customize-widgets.php on line 215
    [28-Nov-2014 18:41:56] PHP Notice: ??????? get_current_site_name ? ?????? 3.9 ????????? ??????????! ??????????? get_current_site(). in /var/....ru/wp-includes/functions.php on line 3201
    [28-Nov-2014 18:42:00] PHP Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /var/....ru/wp-includes/functions.php on line 3370
    [28-Nov-2014 18:42:00] PHP Warning: Cannot modify header information - headers already sent by (output started at /var/....ru/wp-includes/functions.php:3370) in /var/....ru/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 591

    And here is smth new for me (what is it??):

    [28-Nov-2014 18:42:00] PHP Notice: Undefined variable: wp_version in /var/....ru/wp-content/plugins/ad-sharing/ad-sharing.php on line 128

  • Jack Kitterhing
    • Code Norris

    Hi there @Eugene,

    Hope you're well today and thanks for sending the file.

    Everything looks good with the server setup, can you replace this line in your wp-config.php

    define('WP_DEBUG', false); with this

    ini_set('log_errors','On');
    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    And see if the errors show and if anything is output to wp-content/debug.log

    Thank you!

    Kind Regards
    Jack.

  • Eugene
    • The Incredible Code Injector

    Hi!

    I did what you said - but there are no /wp-content/debug.log file created...
    But the /wp-admin/customize.php behaved strange - watch the video pls:
    http://rghost.ru/private/59614622/72512d7b225de4525bdc068e46b1b3fa
    (black button to download the video)

    Arrr, we do need to solve the problem. Our localisation plugin gets promblems when there is " symbol in the translation...so we have translate everything manually at a local comp... Help pls.

  • Vinod Dalvi
    • WP Unicorn

    Hi @Eugene,

    Also here is some fresh info form debug.log (may be this can help some how):

    I did what you said - but there are no /wp-content/debug.log file created...

    I am a bit confused regarding your above two statements in the first statement you have shared info form debug.log and in your other statement you said there are no /wp-content/debug.log file created so in your first statement are you referring the debug.log file created else where?

    The /wp-content/debug.log file might not created due to wp-content directory permission so either make this directory writable or create the /wp-content/debug.log file manually.

    video pls:
    http://rghost.ru/private/59614622/72512d7b225de4525bdc068e46b1b3fa
    (black button to download the video)

    I watched your video but couldn't reproduce the issue on my test site.

    Could you please tell us a bit more information about which language you are using and related information so that it will help us to reproduce this issue and to resolve it?

    Arrr, we do need to solve the problem. Our localisation plugin gets promblems when there is " symbol in the translation...so we have translate everything manually at a local comp... Help pls.

    Which localisation plugin are you using?

    Is the above mentioned issue gets resolved when you deactivate the localisation plugin that you are using?

    Regards,
    Vinod Dalvi

  • Eugene
    • The Incredible Code Injector

    I am a bit confused regarding your above two statements...

    The problem must be caused by the code I added (which you asked to add). without this code debug file is creating.

    which language you are using

    Russian

    and related information so that it will help us to reproduce this issue and to resolve it?

    I don't know. Ask Jack Kitterhing pls - he reproduced this SAT NOV 22 2014, 11:02:35 PM.

    Which localisation plugin are you using?

    CodeStyling Localization

    Is the above mentioned issue gets resolved when you deactivate the localisation plugin that you are using?

    This plugin does not effect this at all. It was working well sometime ago as everything but now it is suffering as other things. I don't know what exactly changed from that time...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.