"Mail delivery failed: returning message to sender" error with every mail

Hello.
Every time i try to send out emails from the Mass Email Sender plugin, i get an error email back, from every mail the Mass Email Sender has sent the mails to.

Here's a copy of the mail:

Subject: Mail delivery failed: returning message to sender
Content:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  henriettekahlert@hotmail.com
    Domain bloggerspoint.dk has exceeded the max defers and failures per hour (5/5 (11%)) allowed. Message discarded.

------ This is a copy of the message, including all the headers. ------

Return-path: <support@bloggerspoint.dk>
Received: from [77.66.108.55] (port=42708 helo=www.bloggerspoint.dk)
	by web31.meebox.net with esmtpsa (TLSv1.2:DHE-RSA-AES256-GCM-SHA384:256)
	(Exim 4.85)
	(envelope-from <support@bloggerspoint.dk>)
	id 1ZJ0LZ-001zaA-BU
	for henriettekahlert@hotmail.com; Sat, 25 Jul 2015 16:22:43 +0200
Date: Sat, 25 Jul 2015 14:22:41 +0000
To: henriettekahlert@hotmail.com
From: Bloggers Point <support@bloggerspoint.dk>
Subject: =?UTF-8?Q?Tips_til_at_ops=C3=A6tte_din_blog?=
Message-ID: <c71f2354563f6914ac2c61041176ed97@##str_replacement_1##>
X-Priority: 3
X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
MIME-Version: 1.0
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="b1_c71f2354563f6914ac2c61041176ed97"
Content-Transfer-Encoding: 8bit
X-OutGoing-Spam-Status: No, score=-2.9

--b1_c71f2354563f6914ac2c61041176ed97
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

So if we send out about 1000 emails to all of our users, then we will get 1000 emails back saying the "Mail delevery failed". The only mail that seems to get thru, is the one to our own mail address: info@bloggerspoint.dk