Mailchimp add-on not working with membership2. I had

Mailchimp add-on not working with membership2. I had to deactivate it because it was automatically unsubscribing all NEW subscribers.

Have granted access in the wp-admin dashboard.

  • Adam Czajczyk
    • Support Gorilla

    Hello Robin,

    I hope you're well today and thank you for your question!

    I'm sorry that didn't work for you as expected. Could you please help me a bit more with this? I'd like to know
    - did you set the "Automatically opt-in new users to the mailing lists" option on?
    - was different lists setup for "Registered users mailing list (not members)", "Members mailing list" and "Deactivated memberships mailing list"?
    - by "NEW subscribers", do you mean a) newly registered WP users b) users that just signed up for a membership regardless whether they already are WP users or not c) subscribers that are not WP users and/or members and subscribed using some different way (e.g. subscription form created by other plugin)?

    Please advise!
    Best regards,
    Adam

  • gerard
    • Design Lord, Child of Thor

    Hi Robin,

    I just had a look at the screenshot you sent.

    May I advise you, in the future, to blank out your API keys when sharing a screenshot where they show up? It is always best to keep your API key confidential.

  • Milan
    • WordPress Wizard

    Good advise Patricia9 ,

    I went ahead and removed those screenshots. :slight_smile:

    Robin Bennett whenever you upload any screenshot or share any credentials with us here, make sure that you are not disclosing any sensitive information in it. Doing so is not advisable here as our this support forum is quietly well indexed by Google and most importantly its public.!!

    Best Regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.