Main site as multi site needs Pro Level, but to hide level?

I haven't quite figured out how I can build out the main site of a multisite install to make use of the highest level in Prosites, but I also do not wish to show this level in upgrades. I am sure I am not making sense on this, But what I have is a blog template set up, prosites set up, and the main domain to be the parent site. When I show the upgrades possible for prosites, it also shows the level with everything turned on that I need to build out the main site.

I would like this somehow turned off. Is that possible?

Possible I am doing this all the wrong way.

Regards,

Ciaran

  • cmwwebfx

    Oh dear,

    Then I think I made a big BooBoo.... when in dashboard of the networks admin, I can see sites. In the Sites list I see that I have the main parent site in that list, and it has a prosites level to it.
    Possibly this is where I have made a mistake? I also made the parent site as the Blog Template. But I realise I should have made a new site, called it something else, then saved that as the template.

    Not sure how I need to fix the issue I have now.

    Ciaran

  • aecnu

    Greetings Ciaran,

    Now we have a real problem here that will not be so easy to fix - where a re-install is most appropriate and would take less time to do then to try to hunt down all the possible/probable problems there may be.

    I would like to start at the beginning though answering your questions with clarification starting from the top.

    First of all the main site does not need a level of any kind because it is the "main site" and will have access to all plugins and themes within the network with the exception of a theme marked as "none" in the Pro Sites Premium theme section.

    Second when logged in as network admin you can activate a plugin or theme for any site in the network that you choose.

    Lastly if I understand you correctly, you used 'New Blog Templates" on your main site?

    (this is why I decided you should do a re-install or roll back to your last backup before activating this on your main site, if not maybe we can salvage the network without a re-install)

    Please advise.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • cmwwebfx

    Hi there Joe,

    Thank you very much for your time in the great response. Right now I only have 2 test sites installed, and now understand that what I should have done was create a new site specifically that will be a clone template for all new sites created from that. However, is there a way I can just remove the blog template from the main parent site, create a new site, use that as a template?

    Right now I have a very important online petition running to hold off Woolworths from taking over a bricks and mortar market for stall holders. So reinstalling the site is not really an option. Each day I am getting petitions submitted, and this has to be submitted as CSV on 21st March. But then my other problem is I have to have the site ready to be launched as a multisite for registrations on 16th March..

    Having the petition running right now is the only reason holding me back from a reinstall.

    Unfortunately I did not make a backup before creating the Blog template.

    I now understand that I should be activating plugins as network admin for the parent site.

    In Prosites "Premium Plugins"setting page, there are levels showing that I have made

    Level 1
    Level 2
    Level 3
    And 2 additional levels: None, Anyone (Can you please describe these both)

    At the moment I have all set to none, but can see them in a new site.

    Ciaran

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.