Main site URL without www sends users to registration page

This is annoying!

I have a multisite install with BuddyPress 1.5 running.

Visiting works fine and you go to the main site's home page.

But, visiting just (no www) redirects the user to

I'd rather this didn't happen.

Any ideas?

  • Mark de Scande
    • Syntax Hero

    mmm i had this problem be for i think i fixed it as follows

    Make sure all you DNS Stuff is correct
    Look for Domains and make sure all are correct

    Wordpress Look at your .htaccess

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Also have a look at your site details at you host maby ask them to add a cname entry that point to your ip as well as your domain name some time they dont like doing this

    If you type in any of the 2 sites below it will take you to or

    Again i just got it right with all the steps i can not tell you witch one was the culprit.

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Dave,

    Golden rule: Multisite *hates* WWW. If you possibly can, get rid of it by changing your site URL settings etc.

    It's not so easy to change the site URL in Multisite so if this is a new site you might wanna consider exporting any content and then doing a fresh install.


  • DavidM
    • DEV MAN’s Mascot

    Hiya davebriggs,

    I actually have a couple multisites setup in that way and yeah, the non-www version of the domain doesn't go to the respective page on the site. Whereas a multisite setup with a non-www domain would still yield the proper location.

    As Phil mentioned, possibly the best method is to copy out your content and reinstall.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.