Make an Appointment page keeps loading forever after making an appointment

I was not sure if it happens only to us but I received feedback from customers who describe the same problem; every time you make an appointment on our page (http://www.glitteratinaillounge.com/make-an-appointment/), you often do not get the pop up confirmation and a small round circle saying "wait" or "loading" continues to turn forever and nothing happens. This leaves everyone confused and uncertain whether the reservation was actually made and if we actually received the appointment. Email messages are sent though. As I said, we have tested this from several locations and received numerous messages from users regarding this.

I have a screen shot of what happens, it will stay like this forever https://dl.dropboxusercontent.com/u/2229935/Make%20an%20Appointment%20Loading%20Forever.png

How can we fix that?

  • Jack Kitterhing
    • Code Norris

    Hi there @randush

    Thanks, I've just tested this and you are 100% correct, the waiting symbol never stopped turning/loading, but I already had received a confirmation email.
    I can't replicate it on my test install though.

    I've flagged the lead developer on this to provide his valuable insight.

    Thank you for being a WPMU DEV member!

    Kind Regards
    Jack.

  • randush
    • Design Lord, Child of Thor

    Just saw your test appointment. We also noticed that forever-turning circle when we book an appointment via the backend, again it keeps turning and we have no way of knowing if the appointment was entered, if an email was sent. When we give up and hit refresh, the appointment may or may not be there, if it is not we have to try to enter it again.

    See screenshot https://dl.dropboxusercontent.com/u/2229935/Make%20an%20Appointments%20Forever%20Circle.png

  • pxwm
    • WP Core Meltdown

    Hi,

    Could you please confirm if you have the latest A+ plug-in v1.2.7?

    Have you tried using the default theme - twenty twelve to see if this resolves the problem?

    If the site is live you may wish to setup a demo site to test the above.

    Regards
    SteveB

  • randush
    • Design Lord, Child of Thor

    Dear SteveB,

    Unfortunately, I have had several issues with this plugin and I keep being asked to revert to the default theme to check whether the problems persist. The thing is, I lose all of the hard work I put into customizing everything again and again and I can not keep doing that every time.

    I do have the latest version of Appointments+.

    Thank you.

  • pxwm
    • WP Core Meltdown

    Hi,

    Could I suggest that if you take a home directory and database back-up before you change the theme then if changing the theme causes problems you have a back-up you can revert back to.

    The reason I suggested you revert to a default theme is in case there is a problem with the theme functions/php file.

    Could you please confirm if you have added any bespoke A+ code to the functions.php or if you have added any shortcodes within a wordpress page.

    Have you other plug-ins and if so have you temporarily disabled these to check if they are causing a problem?

    Regards
    SteveB

  • Hakan
    • The Incredible Smush

    Hi randush,

    I get an GCal API error "Uncaught exception 'Google_AuthException' with message 'Error refreshing the OAuth2 token" when trying to make an appointment on your website. Can you please click "Test connection" and if you are using Sync mode can you also "import and update events now" for Google Calendar?

    Cheers,
    Hakan

  • randush
    • Design Lord, Child of Thor

    @Hakan

    I have not gotten a gCal error since we have fixed the installation problems in the beginning. I am using the A+ -> gCal (Only export appointments) method and I can not see where is "Import and update events now" is located.

    When I do a "Test connection" the annoying "wait" circle starts turning, the screen turns blank and nothing happens. I have tried it several times. See screenshot https://dl.dropboxusercontent.com/u/2229935/gCal%20test%20blank.png

    When I check my Google Calendar in Agenda mode, none of the appointments are shown (I only have completed appointments at the moment so I am not sure if it supposed to show appointments that were already completed).

    gCal "test connection" and sending appointments from A+ to gCal used to work before the new update.

    Thank you.

  • randush
    • Design Lord, Child of Thor

    @pxwm

    I confirm that I have not added any code to functions.php or anywhere for that matter, I did create a password protected page and inserted some A+ shortcodes so the team could have a single location where they can view our upcoming appointments.

  • randush
    • Design Lord, Child of Thor

    I've set Add Google Calendar Button "No" but it still appears but it still appears in the "My Appointments" area after the reservations have been made.

    It also seems to take forever for auto-refresh to reload the page with the selected service, for the time to be inserted after clicked and for the reservations confirmation popup warning to be displayed. Very slow.

  • Hakan
    • The Incredible Smush

    Hi Randush,

    Your server time is 5-6 minutes ahead of the current time. This is not about timezone, but your server is *really* out of time.

    You can see this in Settings>General on left side pane (Check UTC and local time values with the actual time).

    Please contact your hosting company to set server time correctly.

    Cheers,
    Hakan

  • Alexander
    • DEV MAN’s Mascot

    Hello @randush,

    So how's this coming?

    I just wanted to touch base with you on this issue, as it's been a few days since we've heard from you. I hope you were able to get everything worked out!

    To further expand on the previous response, anytime it comes to using an external API (such as google calendar) it's quite important for the servers to be on the proper time. API's generally use timestamps to assist with authentication, or to filter out traffic that doesn't look right.

    So it's quite possible that this is causing some of your speed issues.

    Anyways, I just wanted to touch base and see how you were doing. Let us know if you still need assistance here!

  • pxwm
    • WP Core Meltdown

    Hi Randush,

    You mentioned in an earlier post:-

    "I've set Add Google Calendar Button "No" but it still appears but it still appears in the "My Appointments" area after the reservations have been made."

    To 'hide' the GCAL button you need to add the shortcode: [app_my_appointments gcal="0"] in the appointments page

    or if you read the changes to the latest version v1.2.8 Hakan has introduced another method of 'hiding' the button.

    Regards
    SteveB

  • randush
    • Design Lord, Child of Thor

    Hello All,

    To have everyone on the same page; According to @Hakan, the issue was definitely related to Gcal integration, I have followed his instructions and disabled Gcal for now awaiting a solution from him.

    I did contact my hosting company (Dreamhost) regarding this and this was their response:
    "Hello,
    The NTP service on the lightning server has been restarted and the server
    time should now be correct. Also we were not able to locate the specific
    cause of slowness on the http://www.glitteratinaillounge.com/ domain as
    this currently loads at a good speed and we were not able to find any
    problems on the server end."

    I was not aware of the 1.2.8 update, I will update now and add the shortcode to disable the Gcal button as you suggested.

    So, as you see, I am waiting for a solution to come from your side.

    Thank you.

  • Jack Kitterhing
    • Code Norris

    Hi there @randush

    I hope you are well today.

    Thank you for the updates and additional information, have you added gCal integration back? If so have you tested it and is it still as slow?

    I'm afraid Hakan, doesn't work here any more, but I'm more than happy to help you resolve your issue and a new developer has been assigned to Appointments+ so if need be, I can also flag him if needed.

    Thank you for being a WPMU DEV member! And have a great weekend.

    Kind Regards
    Jack.

  • randush
    • Design Lord, Child of Thor

    Hello Jack,

    Thank you for following up on this issue, Jack. Please review the conversation above and see my attached screenshots, kindly flag the developer in charge of Appointments+ as well. Everything being slow is another issue, the issue here is the confusing forever-loading circle and the inability to complete an appointment. Things seem to be working with Gcal disabled (Hakan's instructions). I will try to add Gcal integration again tomorrow and we will see if the problem was solved.

    Thank you.

  • Jack Kitterhing
    • Code Norris

    Hi there @randush

    I hope you are well and thank you for the additional feedback.
    I have just flagged the lead developer on this plugin now. I have also just done a test appointment and can see as you said, when Gcal isn't being used, it seems to work fine, I got the confirmation box and everything. We'll await to hear from the developer on this.

    Please let me know once Gcal is added back in and I will take another look for you.

    Thank you for being a WPMU DEV member and thank you for your patience on this issue.

    Kind Regards
    Jack.

  • pxwm
    • WP Core Meltdown

    Hi,

    I can confirm that GCAL works fine on our A+ website.

    As part of your GCAL integration you may wish to recheck the private keys are correct as allocated by google.

    I also suggest you re-check the 'google calendar' main tab settings and if you have more than one service provider and you have created unique private keys for each of them make sure the GCAL settings are correct in the main calendar and the service provider Wordpress user profile.

    Hi Jack - Sad about Hakan no longer being on the payroll as he was a great asset to the A+ plug-in. What is he doing now?

    Regards
    SteveB

  • Vladislav
    • Dead Eye Dev

    Hello,

    Additionally, as for the slowness issue, can you please temporarily try to add this define to your wp-config.php and see if it helps with the long response time issues:

    define('APP_GCAL_DISABLE', true);

    This will effectively disable the Gcalendar API calls entirely, and hopefully we'll be able to tell if there is a difference in the response times.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.