Make Easy Bloggin Mandatory

I would love to be able to basically restrict users to only being able to use the easy blogging pannel with the exception of admins. Is this easily implemented or would it take some effort. Thank you for the great plugin. I love it and works like a charm with 3.0.