managed and manual snapshots always time out even though execution is set to 36000 seconds

Hi,

I have read and implemented all the suggestions from your recent snapshot support forum threads yet it still does not work on the 3 websites I am testing it on. Before it was producing memory error but this was fixed since the host increased it, not it is always producing connection timeout error even through its increased to 36000 seconds which is very high you must agree.
Thus far I have:
1. Asked the host to increase memory and execution timeout, now set to 1024mb and 36000 seconds respectively
2. Added debug log settings to wp-config.php
3. Tried to reduce the snapshot chunk size through wp-config settings
4. Tried to create manual snapshot and managed snapshot to your server by manually clicking "backup now" button
5. Tried deactivating and again activating the snapshot plugin

Snapshot is simply not working on any of the 3 sites I am testing it on. One one it never worked, on others it worked 6th January when I first installed it but haven't worked since.

The main website where I would like to get it to work and where it never worked is http://polinet.website
I have enabled support access to the site and I am attaching here my debug log which has no mentions of snapshot errors in it.

  • Polina

    Hi Faydra,

    I did as you suggested and disabled all my plugins leaving ONLY snapshot plugin enabled and still sometimes after step 34 I see the dreaded
    Request Timeout
    This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.

    I only have the 1 theme installed and its the same theme as on my other site. One other site I was testing the backup actually succeeded and its with the same host. What can I do next to troubleshoot? My site is slightly larger than the other site that succeeded but by no means huge, still just a basic web developer's portfolio. And certainly smaller than some of the client's sites I wish to backup with this plugin.

    Your assistance highly appreciated.

    • faydra_deon

      Apologies, I didn't want you to deactivate the plugins. I just wanted you to exclude them from the Snapshot my change the option from "Include common files: Themes, Plugins, Media (wp-content/uploads)" to "Include selected files," and then checking everything but the plugins.

      With one of my clients, I can to exclude plugins. With another, I have to exclude Media Files (because her images are so large they cause the backup to timeout).

      Even with the plugins deactivated, they're still being included in the Snapshot, but if you explicitly indicate that the Snapshot should skip them then the backup may finish. If it does, then you know the issue is with one or more of the plugins.

      Faydra...

  • Polina

    I have also upgraded wordpress and all plugins to the latest versions before I ran the test with no plugins enabled. Nothing seems to help.

    Are there any plugins or way to test the server time out? The host advised they changed it to 36000 seconds for me but is there any way to check how much it is? I see memory limit is reported in the manual snapshot running window at the top, is there any way to report the timeout limit the same way?

  • Polina

    Sorry, but how do I exclude plugins from the managed snapshot option? In the managed snapshot the only options I see are schedule and log options.
    If I exclude plugins in the manual snapshot is that going to affect the managed one?

    And the bigger issue is, if you are excluding certain parts of wordpress in backups, then what good is that backup? Frequently it is before upgrading plugins that I do a backup since they might break and I need to roll back to pre upgrade. If I exclude plugins I don't have this option.
    Same if there is some issue on the server, if I don't have a full backup how can I restore after an issue or some complete wordpress disaster or hack attack?

    Please confirm that you are not able to make the plugin function as a full backup solution not for me nor for your clients so I can stop wasting my time with this one attempting to introduce the full suite of wpmudev plugins to my clients as a value added paid service and instead focus on the solutions that do work like updrafts.

    • faydra_deon

      I personally have 40 WordPress sites, and managed and manual backups work fine on every, single one of my sites. I host on a VPS with Media Temple. I also only have the issue with backups not working properly on only two client sites, and I have many more than two clients.

      The problem with those two are their hosting providers, but because they pay me for maintenance I have to have a workaround to be able to get their sites back online if something happens.

      For one, I back up everything but plugins, and then I FTP in and copy all their plugins to my personal storage. For the other, I back up everything but the uploads folder, and then I FTP in and copy the entire uploads folder to my personal storage. These are my workarounds, because I can't get these two clients to understand that Network Solutions and GoDaddy are horrible hosting solutions.

      As for managed backups, I don't do managed backups on those two clients' sites, because no backup solution works without the above-mentioned workarounds with their hosting. I've tried other backup plugins on their sites thinking the issue may be with Snapshot, but no backup plugin I've tried works. I consistently get time-out errors no matter what backup plugin I use.

      I have managed backups on all my other clients' sites, and they work fine. I have managed backups on about ten of my own sites, and they work fine. The others I do manually, because I have so many sites I don't want them all to eat up my free 10GBs of storage.

      I've been a member of WPMU Dev since 2011, and I actually only keep paying every year to make sure I have updates to Snapshots, because it's actually the only one I really use on every, single site of my own and my clients'.

      As I'm not familiar with your hosting company, I can't say whether it's at that level or somewhere else. I truly didn't mean to waste your time.

  • James Morris

    Hello Polina,

    I hope you are well today.

    First, faydra_deon, thank you very much for your valuable input on this thread. You've provided a wealth of information and experience. :slight_smile:

    Polina,

    I've checked out your site and your settings look very generous. More than enough to run Snapshot successfully. The only setting that I see is low is WP_MEMORY_LIMIT which is 40MB. Yet, your WP_MAX_MEMORY_LIMIT is 1024MB. You may want to add the following directive to your wp-config.php file.

    // Increase WP Memory Limit
    define('WP_MEMORY_LIMIT', '512M');

    Now, if that does not work, the remaining issue that can cause failure is I/O limitations on disk activity. Since Snapshot does a great deal of reading and writing to disk, this can cause your hosting to reach it's I/O cap if your hosting provider has a strict limitation on this. This is most common on shared hosting packages.

    So, if the above directive added to your wp-config.php does not work, you may want to contact your hosting provider and ask them if they are capping your I/O activity and at what level it is capped at.

    Snapshot works very well on the majority of shared providers, but as faydra_deon has stated, lower quality hosts can be problematic.

    Best regards,

    James Morris

  • Polina

    Hi,

    Thank you, James, for your input and apologies to Faydra for my comments. I am new to this community support thing and assumed I was speaking to wpmu tech support so suggestion to implement work arounds instead of attempting to solve the problem didn't seem right to me.

    I tried the wp limit config fix as James suggested but it is still timing out.

    I have also been monitoring cpanel stats during the backup which show IOPS and I/O Usage in KB/s but neither of those seemed to have been exceeding any limits, in fact no limits seem to be set as no matter what those figures were, it was still showing 0% of limit. I did however notice the CPU usage hovering around 99/100% most of the time but I doubt that the host would time out the process every single time at the exact same moment due to CPU usage.

    I have tried Updraft with the exact same configuration and it works just fine putting my backup on my Google Drive within a few minutes. As I said it;s a relatively small static site so not sure why snapshot is having so much trouble.

    I will continue testing it on the other sites but after spending 4 days trying various solutions I found on these forums to get snapshot working on my main one I just give up.

    Could you please advise regarding the following points:
    1. Even if snapshot times out it still seems to create a successful backup record in the All Snapshots list and files on the server. I suggest there should be a check in place showing those are INCOMPLETE backups and can not be used for restore.

    2. Those snapshots would also report as if being stored on Google Drive while no files ever made it there.

    3. Even when I delete the snapshots from all snapshots list the files still remain on the server contributing to my disk quota and I have to manually delete them from the server in addition to deleting the record from the All Snapshots page.

    One note that the one site the snapshot did eventually succeed on is with the same host on a different account with NO special memory or execution time out limits implemented so I doubt hosting environment is to blame.

    On another site on my cpanel account which is a multi site the managed and manual snapshot sometimes works sometimes doesn't. I will monitor to see if the scheduled backup works on its own without me manually launch it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.