Managed Back Up to Cloud not working

My full managed backups won't work at all - at first it was sending me to my hosting provider with a 500 error. I read in their documentation that it could be a problem with .htaccess or php.ini. Yesterday I added a php.ini file to increase limits and followed this article https://premium.wpmudev.org/blog/increase-memory-limit/ so I thought it might be to do with that.

I tried to delete the php.ini file to see if that would work but then I got this error "Aw shucks, something went wrong Instead of the beautiful response we expected, we got this:

<empty response>"

So I put the file back in wp-admin and I'm still getting the error.

Can you help before I get myself in more of a mess?

I have individual subsites backed up locally with Snapshot Pro and they seem to be ok, it's just the full Managed back up that's having a problem.

I have granted access.

Thanks for your help.

  • Rupok

    Hi Stephanie,

    So sorry for the inconvenience you are having. Let's try to fix this for good.

    Can you please go to "Snapshot > Managed Backup" section and put a tick on "Enable logging" option and select "Info" for all four options? Please check the attached screenshot for reference.

    Now try to backup once again. If it fails again, can you please click on "View your log file" link and paste the debug data here? If there are lots of lines, please copy those, paste those in a text file and attach that text file witn your reply. That will give us valuable insight regarding the issue.

    Besides the php.ini file method, there is another way described in that article. That is editing your .htaccess file and adding constants there to increase your allocated memory. Did you try that? Can you please confirm?

    Can you also try reducing file chunk size by adding the following line in your "wp-config.php" file?
    if (!defined('SNAPSHOT_FILESET_CHUNK_SIZE')) define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    It will reduce file chunk size to 100 files from 250.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If nothing above helps in resolving this issue, would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    • Stephanie

      Hi Rupok,

      Thank you for your help.

      The same issue happened again - there were only a few lines so here they are:

      [snapshot][2016-11-23 16:57:22][Info] Starting backup
      [snapshot][2016-11-23 16:57:38][Info] Created the backup and added the queues
      [Queue][2016-11-23 16:57:53][Notice] Fetching [250] files as chunk 1
      [snapshot][2016-11-23 16:57:56][Info] Successfully processed backup files chunk
      [Queue][2016-11-23 16:58:04][Notice] Fetching [250] files as chunk 2
      [snapshot][2016-11-23 16:58:05][Info] Successfully processed backup files chunk
      [Queue][2016-11-23 16:58:12][Notice] Fetching [250] files as chunk 3

      I have already given support access if you wanted to have a look.

      I didn't want to do the plugin conflict test until I'd managed to move a copy of my site to a test site (which I'm also having trouble doing) as I didn't want to disrupt any of the subsites while I was testing. I can't do that now but I will do it when I get a chance maybe later tonight or in the morning.

      I will go in and add that line to my wp-config file now.

      Thanks again.

  • Stephanie

    Hi Rupok,

    I just tried to run the backup again after changing the wp-config file and it seemed to go a step further. Here's the log:

    [snapshot][2016-11-23 16:57:22][Info] Starting backup
    [snapshot][2016-11-23 16:57:38][Info] Created the backup and added the queues
    [Queue][2016-11-23 16:57:53][Notice] Fetching [250] files as chunk 1
    [snapshot][2016-11-23 16:57:56][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 16:58:04][Notice] Fetching [250] files as chunk 2
    [snapshot][2016-11-23 16:58:05][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 16:58:12][Notice] Fetching [250] files as chunk 3
    [snapshot][2016-11-23 17:24:05][Info] Starting backup
    [snapshot][2016-11-23 17:24:16][Info] Created the backup and added the queues
    [Queue][2016-11-23 17:24:27][Notice] Fetching [100] files as chunk 1
    [snapshot][2016-11-23 17:24:30][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 17:24:39][Notice] Fetching [100] files as chunk 2
    [snapshot][2016-11-23 17:24:39][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 17:24:47][Notice] Fetching [100] files as chunk 3
    [snapshot][2016-11-23 17:24:48][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 17:24:54][Notice] Fetching [100] files as chunk 4
    [snapshot][2016-11-23 17:24:55][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 17:25:04][Notice] Fetching [100] files as chunk 5
    [snapshot][2016-11-23 17:25:04][Info] Successfully processed backup files chunk
    [Queue][2016-11-23 17:25:12][Notice] Fetching [100] files as chunk 6

    Thanks

  • Rupok

    Hi Stephanie,

    Thanks for granting Support Access. I could see the issue in action. But in console, it said that this issue happened because of 500 Internal Server Error. So again I'm back to thinking that this is because of lack of memory allocated.

    When you edited your .htaccess file for increasing memory, what value did you put for "php_value memory_limit" ? Can you please try assigning 1024MB? So you should be adding the following line in your .htaccess file:
    php_value memory_limit 1024M
    Please also do one more thing. Open "wp-config.php" file and add the following line there and save:
    define('WP_MEMORY_LIMIT', '1024M');

    Please let us know how it goes this time. And please also provide your server error log. That will give us more clear idea regarding what is causing this 500 Internal Server Error.

    I'm looking forward to hearing from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Stephanie

    Hi Rupok,

    Thanks for that.

    I never changed the .htaccess file as I thought it had worked with the php.ini. There are lots of .htaccess files - which one do I put the code in? (Sorry if that's a really stupid question but I'm quite new to all this).

    Also Defender has suggested I change this back to default (the theme I'm using suggested I change it to 128M) could this be causing the issue and is it safe to get Defender to fix it?

    Thanks so much for your help - I've added the line to the wp-config.php file.

    Cheers!
    Steph

  • Nithin

    Hi Stephanie,

    Hope you are doing good today. :slight_smile:

    I never changed the .htaccess file as I thought it had worked with the php.ini. There are lots of .htaccess files - which one do I put the code in? (Sorry if that's a really stupid question but I'm quite new to all this).

    You'll have to add the rules mentioned by Rupok, in the .htaccess file located in your root directory. Most of the other .htaccess files are created by plugins, in order to add any rules related to the settings made.

    php_value memory_limit 1024M
    php_value max_execution_time 180

    Adding the above code in your .htaccess file in your root directory should increases the memory, and max_execution_time

    Also Defender has suggested I change this back to default (the theme I'm using suggested I change it to 128M) could this be causing the issue and is it safe to get Defender to fix it?

    It's highly recommend that you do not edit your WordPress core files. If your theme had suggested to change to 128M, you should have added that in your wp-config.php file, which is located in your root directory.
    For eg, this should you have defined the following code in your wp-config.php file, instead of editing the default-contants.php file.
    define('WP_MEMORY_LIMIT', '128M');

    Since you are still getting the 500 error, please add 1024 instead of 128 in your wp-config.php file, ie:
    define('WP_MEMORY_LIMIT', '1024M');
    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    Once you have made the above changes, you can check whether the values have increased or not, under WPMU DEV > Support > SYSTEM INFO

    If you are still having issues with increasing your memory limit, and max_execution_time, would recommend you to get in touch with your host, in order to increase these values.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.