Managed backup error

I have been working with Violeta from chat support and the chat got dropped. I need to leave now but will check back later today to see if the issue has been resolved. Unable to generate a managed backup.

  • viobru
    • Recruit

    Hi, Johanna!

    It’s me again, hope you are doing great :slight_smile:

    To continue checking what could be causing this, could you please try increasing the memory_limit to 512 and also enable WP_DEBUG to check if there is any error logged after increasing it and trying to create a new managed backup? If so, please change the debug.log file extension to .txt and share it on this thread.

    We look forward to hear from you. Have a nice day ahead!

    Kind regards,

    Violeta

  • Rupok
    • Support Ninja

    Hi Johanna,

    I’m so sorry to hear the inconvenience. Unfortunately, the portion of the debug log you provided doesn’t give us any insight regarding the backup failure. In your given screenshot, I can see only some PHP Warnings which should not stop the backup process. Can you please provide us the full debug.log file so we can try to find out what’s happening?

    Moreover, can you please add the following lines to your wp-config.php file and save, and then try to create a managed backup again?

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);

    Please let us know the result. I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,

    Rupok

  • Patrick Freitas
    • Staff

    Hi Johanna

    Hope you are doing well.

    Thank you for debug file, I see some denied access on plugins.

    Wouldn’t you mind please, send us some information and we can take a closer look for you?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: “Attn: Patrick Freitas”

    – Site login URL:

    – WordPress admin username:

    – WordPress admin password:

    – FTP/SFTP credentials

    Host:

    Username:

    Password:

    Port:

    – cPanel credentials

    Host:

    Username:

    Password:

    – Folder path to the site in question:

    – Link back to this thread for reference

    – Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.

    Best Regards

    Patrick Freitas

  • Jayman Pandya
    • Recruit

    Hi Johanna,

    Thank you for providing the details. A plugin conflict test will have to be done to isolate the problem.

    This test should take 30 mins and you can follow the below steps.

    Step 1 : Login to the FTP of your site and browse to wp-content folder

    Step 2 : Rename the “plugins” folder to “_plugins”

    Step 3 : Create a new “plugins” folder

    Step 4 : Now move the first folder from “_plugins” to “plugins”

    Step 5 : Go to the website and try to see if the issue is solved or not

    Step 6 : Repeat Steps 4 & 5 till the symptoms comes back again

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Please write back to this thread with your observations so that we can assist you further.

    Thank you

    Jayman

  • Johanna
    • Flash Drive

    Hello Jayman,

    Thanks for your help. I need some further clarification on the process you have described. For example, if I change the plugins folder to _plugins, then move the plugins over to test one at a time, how do I test them without going to the Wp-Dashboard?

    The only thing not working is the managed backup. I previously disabled all other plugins and the Snapshot managed backup still did not work. Is this not the same process essentially? (Note that snaphots work, just not managed backups).

    Sorry but I am a bit confused about the exact steps I need to take here.

  • Kasia Swiderska
    • Support nomad

    Hello Johanna,

    That would be the same process, but since you have already done this, we can exclude this is a problem with another plugin.

    I checked your site and error logs and there might be a problem with upload path. Since I don’t have access to your database, please check table wp_options (wp_ is the prefix of the table, it will be different for yours). In that table, find upload_path (if you are using PhpMyAdmin, it will be probably on the second page of records in table). If there is value there copy it as a backup somewhere safe and then remove it from the table. Save and then see again if you can create a backup.

    Check if everything works on your site after changing this table, if you will see any issues put the upload_path back.

    Let me know how it goes.

    kind regards,

    Kasia

  • Johanna
    • Flash Drive

    Hello Kasia,

    I went through phpMyAdmin and found upload_path. It had a value of 51. I removed it and saved, then tried the backup again. It still did not work.

    I also got the following error/warning from the database (see attached), so I entered the value: 51 back in and saved again.

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Johanna ,

    There was a file permission issue within the snapshots directory and Snapshot couldn’t read/write into a certain file that needs during the upload process. This could’ve been seen via checking the debug.log for the line :

    [21-Feb-2019 14:22:40 UTC] PHP Warning: file_put_contents(/var/www/vhosts/mitchcosecurity.ca/httpdocs/wp19/wp-content/uploads/snapshot/_logs/_sessions/0102000816133c05160f0f_session.php): failed to open stream: Permission denied in /var/www/vhosts/mitchcosecurity.ca/httpdocs/wp19/wp-content/plugins/snapshot/lib/Snapshot/Helper/Session.php on line 82

    I’ve also added a mu-plugin to resize the chunks that Snapshot use to upload your backup to our servers so your hosting environment can’t more easily handle the upload overall.

    You will find 2 new successful managed backups that have been uploaded to our servers as well.

    Tell me if you need any further help!

    Regards,

    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.